Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Spalten vergleichen
#1
Hallo zusammen,

ich muss eine große Anzahl Daten vergleichen und die fehlenden markieren.

Relevant sind eig nur Spalte  C und E.

Mein Problem ist, dass in Spalte C Emailadressen voll ausgeschrieben sind, also z.B. @web.de und in Spalte E nur bis zum @.
Ich möchte also nur die ersten 9 Zeichen der beiden Spalten vergleichen.

Das ist mit Sicherheit möglich, aber ich bin ehrlich gesagt gerade zu doof.

Über jede Hilfe bin ich dankbarSmile

LG
Antwortento top
#2
Moin!
Ist die E-Mail vor dem @ immer 9 Zeichen lang?
Kann ich nicht glauben.
Beispieldatei?

Die ersten 9 Zeichen links erhältst Du mit LINKS(Zelle;9)

Gruß Ralf
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antwortento top
#3
Hallo,

z.B. für Zeile 2: =WENN(ISTZAHL(SUCHEN(E2;C2));"ja";"nein")

Gruß Uwe
Antwortento top
#4
...habe vergessen sie hochzuladen.

Doch die email ist immer gleich lang, da es sich um uni mails handelt, die immer aus 4 buchstaben und 4 zahlen bestehen.


Angehängte Dateien
.xlsx   Test.xlsx (Größe: 8,67 KB / Downloads: 3)
Antwortento top
#5
Na, dann so, wie ich bereits schrieb:
ABCDEF
1MustermannMaxmust5482@...must5482@WAHR
2LustigPeterlust7656@...lust7656@WAHR
3MerkelAngelamerke2235@...FALSCH

ZelleFormel
F1=LINKS(C1;9)=E1
F2=LINKS(C2;9)=E2
F3=LINKS(C3;9)=E3

Die Formel kann man natürlich auch als Grundlage einer bedingten Formatierung nehmen.
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antwortento top
#6
(11.11.2020, 14:30)RPP63 schrieb: Na, dann so, wie ich bereits schrieb:
ABCDEF
1MustermannMaxmust5482@...must5482@WAHR
2LustigPeterlust7656@...lust7656@WAHR
3MerkelAngelamerke2235@...FALSCH

ZelleFormel
F1=LINKS(C1;9)=E1
F2=LINKS(C2;9)=E2
F3=LINKS(C3;9)=E3

Die Formel kann man natürlich auch als Grundlage einer bedingten Formatierung nehmen.

'Das reicht aber nicht, da die andere Liste wild durchmischt ist und es mir nicht um die genaue Position Zeile-Zeile Abgleich geht, sondern nur ob die Email in E irgendwo in C zu finden ist.
Antwortento top
#7
Und warum dann ein (bewusst?) falsches Beispiel??

Ich bin hier raus!  Angry

Nur noch der Hinweis: =ZÄHLENWENN()
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antwortento top
#8
(11.11.2020, 14:44)RPP63 schrieb: Und warum dann ein (bewusst?) falsches Beispiel??

Ich bin hier raus!  Angry

Nur noch der Hinweis: =ZÄHLENWENN()

Das tut mir Leid, war nicht meine Absicht. Habe mein Problem wohl schlecht formuliert:

Die Listen sehen z.B. so aus:

Spalte X 200 Emailadressen
Spalte Y 150 Emailadressen

Reihenfolge der Zeilen ist durchmischt.

Ich möchte wissen, welche Emailadressen bei den 200 Stück mehr sind, als in der Liste mit den 150.
Antwortento top
#9
Hola,


Code:
=WENN(ZÄHLENWENN(Y:Y;LINKS(X2;9))=0;1;0)

überall wo jetzt 1 steht ist die Adresse nicht in Spalte Y vorhanden.

Gruß,
steve1da
Antwortento top
#10
s. Mappe


Angehängte Dateien
.xlsx   Vergleichen.xlsx (Größe: 9,61 KB / Downloads: 3)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste