Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

SVERWEIS und XVERWEIS
#1
Moin moin,

Ich habe eben gelernt, dass man beim SVERWEIS als Matrix definierte Tabellennamen nehmen kann, wodurch diese dynamisch wird. 
Zum Beispiel können drei Tabellen für drei unterschiedliche Monate nach dem jeweiligen Monat definiert/benannt werden.
Mit dynamisch meine ich in diesem Beispiel, dass die Formel je nach gewähltem Monat die Informationen aus den unterschiedlichen Tabellen bezieht.
Die Tabellen sind dabei gleich aufgebaut, nur die Zahlen sind unterschiedlich.

Ich arbeite eigentlich aber nur mit index+vergleich und xverweis.
Jetzt wollte ich gucken, ob ich dasselbe Ergebnis (Abfrage von Informationen aus unterschiedlichen Tabellen anhand von vorgegebenen Werten aus einem Drop-down Menü) mit xverweis auch schaffe bzw. die Formel dynamisch für verschiedene Tabellen funktioniert. 
D.h. wenn ich Januar auswähle, zieht er die gesuchte Zahl aus der Tabelle Januar und wenn ich Februar auswähle, zieht er die Zahl aus der Tabelle Februar.
Nur leider habe ich es nicht geschafft  Angel

Ich weiss nicht, ob das Problem darin besteht dass beim SVERWEIS eine Matrix gefordert wird und beim XVERWEIS eine Suchmatrix. Huh

Jedenfalls, wenn ich beim XVERWEIS als Suchmatrix den definierten Tabellennamen nehme, klappt es nicht sprich: #WERT. 
Meine erste Vermutung wäre, dass der XVERWEIS als Suchmatrix nur eine Spalte erlaubt aber vielleicht habe ich nur irgendwo einen Denkfehler.


Das kleine Beispiel mit meinen bisherigen Ergebnissen habe ich im Anhang.


Angehängte Dateien
.xlsx   Beispiel_sverweis_xverweis.xlsx (Größe: 13,29 KB / Downloads: 7)
Antworten Top
#2
Moin

Eigentlich gehören die Daten in EINE Tabelle und dann FILTER() drüber.
Code:
=SVERWEIS(K2;ERSTERWERT(K3;"Januar";Januar;"Februar";Februar;"März";März);2;FALSCH)
Wir sehen uns!
... Detlef

Meine Beiträge können Ironie oder Sarkasmus enthalten.

Antworten Top
#3
Hi,

wenn du den XVERWEIS nehmen willst, brauchst du tatsächlich eine SuchSPALTE und keine SuchMATRIX. Die kannst du jedoch mit INDEX bekommen:

=LET(X;ERSTERWERT(B11;"Januar";Januar;"Februar";Februar;"März";März);XVERWEIS(B10;INDEX(X;0;1);INDEX(X;0;2);;0;1))

Oder wie bei dir mit INDREKT:
=LET(X;INDIREKT(B11);XVERWEIS(B10;INDEX(X;0;1);INDEX(X;0;2);;0;1))

Oder mit INDIREKT und den strukturierten Verweisen:
=XVERWEIS(B10;INDIREKT(B11&"[Abteilung]");INDIREKT(B11&"[Budget]");;0;1)

Aber besser wäre es auf alle Fälle mit einer Tabelle zu arbeiten und den Monat als weitere Spalte hinzuzufügen statt mit zwölf Tabellen zu arbeiten. Und wenn du statt des Monats ein echtes Datum nimmst, dann brauchst du nächstes Jahr keine neue Tabelle und kannst auch Auswertungen über mehrere Jahre fahren.
Außerdem steht dir dann die gesamte Excel-Funktionalität wie z.B. Pivottabellen, Filter, Datenschnitt etc. zur Verfügung.
Gruß,
Helmut

Win10 - Office365 / MacOS - Office365
Antworten Top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste