Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

SVERWEIS mit mehreren Ergebnissen
#1
Hallo Forum
Da ich ein wenig mit Formeln und auch ein bischen mit VBA zurecht komme habe ich eigentlich alles was ich brauchte ganz gut hinbekommen.
Aber die nUmmer die ich nun machen möchte ist eine zu groß für mich.
Habe auch schon einiges im Netz gefunden und Bücher habe ich auch schon gelesen, aber ich bekomme es nicht hin.
hir hoffe ich auf de geballte Hilfe von euch und wäre darüber sehr dankbar.
Ich schildere mal mein Problem.
1. Ich bekomme zu Schichtbeginn immer eine Excel Datei (Tabelle2) von einem Programm die steht fest und an der Darstellung kann ich nichts ändern.
2. Es geht dabei um fast 10000 Einträge
3. Die Suchspalte liegt nicht am Anfang (Spalte A) sondern inder Mitte (Spalte G)
4 Wenn ich eine Teilenummer eingebe Tabelle 1(A6) sollen mir in Tabelle 1 (Spalte K6.....?) alle Lagerplätze Tabelle2 Spalte D angezeigt werden
 die beiden anderen Anzeigen (Tabelle 1 KNB und Behälter ) wären schöner Beifang aber nicht ganz so wichtig.
wie gesagt bin schon seit einer Woche am basteln aber es wir nix, bekomme immer Falsche werte oder gar keine.
Ich habe mal alle auf Anfang gesetzt damit keine Verwirrung aufkommt.
Wenn ihr mir da helfen könntet wär das super.
Im Anhang die Datei, ich habe schon um die Hälfte eingekürzt.
Vielen dank schon mal im vorraus
Jochen


Angehängte Dateien
.xlsx   WMS.xlsx (Größe: 648,27 KB / Downloads: 6)
Antwortento top
#2
Hi,

hoffe, ich habe dich richtig verstanden:

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDEFGHIJK
3Beispiel Zeile 10Spalte 21Spalte 16
4Teilenummer Tabelle2 Spalte GKNB Nr. Tabelle2 Spalte AABehälter Tabelle2 Spalte Vmehrere Lagerplätze Tabelle2 Spalte D
5
6Trage ich einsoll ausgegeben werdesoll ausgegeben werdensollen alle angezeigt werden
79816936180D059112E11-10-04-04-B
8
9
10

ZelleFormel
C7=SVERWEIS(A7;Tabelle2!$G$1:$AA$328;21;0)
G7=SVERWEIS(A7;Tabelle2!$G$1:$V$328;16;0)
K7=WENNFEHLER(INDEX(Tabelle2!D:D;AGGREGAT(15;6;ZEILE(Tabelle2!$D$1:$D$328)/(Tabelle2!$G$1:$G$328=A7);ZEILE(A1)));"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#3
Hallo
Das ging ja super schnell
Werden in spalte k nun auch mehrere lagerplätze angezeigt?
Es ist nur einer angezeigt. 
Es kann aber auch sein  das es gerade da nur einen gibt 
Jochen
Antwortento top
#4
Hi Jochen, probiers doch einfach aus...
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
Antwortento top
#5
Guten Morgen
also erst mal vielen Dank für die Hilfe
Es funktioniert aber wie schon vermutet wird in der Spalte K immer nur der erste Wert angezeigt.
Es müssten aber auf jeden Fall mehrere Werte in der Spalte K auftauchen.
Jochen
Antwortento top
#6
Hola,

müssen die Werte denn zwingend alle in einer Zelle auftauchen?

Gruß,
steve1da
Antwortento top
#7
Nein sie müssen nicht einer Zeile auftauchen 
Das beste wäre untereinander
Gruss Jochen
Antwortento top
#8
Hola,

dann:
Code:
=WENNFEHLER(INDEX(Tabelle2!D:D;AGGREGAT(15;6;ZEILE(Tabelle2!$D$1:$D$2880)/(Tabelle2!$G$1:$G$2880=$A$7);ZEILE(A1)));"")
Die Formel dann nach unten ziehen.

Gruß,
steve1da
Antwortento top
#9
Hallo
erst mal auf die schnelle Danke
also du meinst die Formel in K 7 un dann nach unten ziehen richtig ?
Probiere es gleich mal aus muss erst noch was tun
Gruß Jochen
Antwortento top
#10
Hallo Leute
Danke Danke Danke 18
ihr seid spitze
es funzt
es sind noch Kleinigkeiten nur der Schönheit aber alles andere passt auf die Schnelle
Nochmals Danke
Gruß Jochen
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste