Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

SVERWEIS auf das vergangene Jahr
#1
Hallo Miteinander,

ich habe folgendes Problem, ich muss in einer Liste den heutigen Tag mit dem selben aus letztem Jahr vergleichen. Um den Wert aus dem letzten Jahr zu bekommen, habe ich mir folgende Formel überlegt:

=SVERWEIS(DATUM(JAHR(C6)-1;MONAT(C6);TAG(C6));'2019'!$B$5:$E$288;3;FALSCH)

Leider bekomme ich so nur ein #NV heraus, obwohl es das Datum durchaus gibt. Ich habe es auch schon mit WAHR hinten probiert, das ändert nichts.

Ich hoffe einer von euch hat noch eine gute Idee, das wäre klasse!

Viele Grüße,

euer Dietmar
Antwortento top
#2
Hallo Dietmar,

du solltest uns den Aufbau deiner Tabelle (incl. deiner Formeln) anhand einer Beispieldatei ziegen. Ich vermute mal, du hast die Daten errechnen lassen; da könnten Rundungsfehler vorliegen.  https://www.clever-excel-forum.de/Thread...ng-stellen
Gruß Günter
Jeder Fehler erscheint unglaublich dumm,
wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#3
Hallo Günter,

leider kann ich das Orginal aus Datenschutzgründen nicht hochladen, ich hoffe diese Beispieldatei tut es auch?

Vlt. jetzt noch wichtig zu erwähnen, manche Daten passen nicht, bzw. gibt es beim anderen nicht, da werde ich die Funktion noch um die WENN Funktion erweitern, aber der #NV Wert wird leider auch bei Daten ausgegeben die ein passendes Gegenstück haben...

LG Dietmar


Angehängte Dateien
.xlsx   Beispieldatei.xlsx (Größe: 12,9 KB / Downloads: 5)
Antwortento top
#4
Hallo, so geht's..:

PHP-Code:
=SVERWEIS(TEXT(DATUM(JAHR(A6)-1;MONAT(A6);TAG(A6));"TT.MM.JJJ");'2019'!$A$5:$B$10;2;FALSCH


Arbeitsblatt mit dem Namen 'Tabelle1'
ABC
5Ergebnis17.893.657
601.10.2019754.330666.894

ZelleFormel
C6=SVERWEIS(TEXT(DATUM(JAHR(A6)-1;MONAT(A6);TAG(A6));"TT.MM.JJJ");'2019'!$A$5:$B$10;2;FALSCH)
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.01] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
Antwortento top
#5
Hallo,

so geht es:
Tabelle1

ABC
110
2Sales
3Umsatz Cu 150
4KalendertagEUR
5Ergebnis17.893.657
601.10.2019754.33000.01.1900
702.10.2019584.39523.04.4439
803.10.2019445.817
904.10.2019921.01104.09.2432
1007.10.2019123.655
1108.10.2019555.92404.04.4603
1209.10.2019111.93510.09.2648
Formeln der Tabelle
ZelleFormel
C6=I21
C7=WENNFEHLER(SVERWEIS(DATUM(JAHR(A7)-1;MONAT(A7);TAG(A7));'2019'!$A$5:$B$10;2;FALSCH);"")
C8=WENNFEHLER(SVERWEIS(DATUM(JAHR(A8)-1;MONAT(A8);TAG(A8));'2019'!$A$5:$B$10;2;FALSCH);"")
C9=WENNFEHLER(SVERWEIS(DATUM(JAHR(A9)-1;MONAT(A9);TAG(A9));'2019'!$A$5:$B$10;2;FALSCH);"")
C10=WENNFEHLER(SVERWEIS(DATUM(JAHR(A10)-1;MONAT(A10);TAG(A10));'2019'!$A$5:$B$10;2;FALSCH);"")
C11=WENNFEHLER(SVERWEIS(DATUM(JAHR(A11)-1;MONAT(A11);TAG(A11));'2019'!$A$5:$B$10;2;FALSCH);"")
C12=WENNFEHLER(SVERWEIS(DATUM(JAHR(A12)-1;MONAT(A12);TAG(A12));'2019'!$A$5:$B$10;2;FALSCH);"")

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Warum hast du aus deinen Daten (plural von Datum) Texte gemacht?
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
Antwortento top
#6
Das Stichwort zu Jockel lautet
  • Gleitkommazahl
  • Gleitkommaarithmetik
  • Gleitkommaproblematik
... falls bei den Datümern Zeiten dabei sind (anscheinend der Fall; habe Datei nicht geöffnet).

EDIT: Lese grad Klaus-Dieter, dass das nicht einschlägig war!
Antwortento top
#7
Hallo, es ginge auch..:

PHP-Code:
=SVERWEIS(ERSETZEN(A6;10;1;8);'2019'!$A$5:$B$10;2;0
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
[-] Folgende(r) 1 Benutzer sagt Danke an Jockel für diesen Beitrag:
  • Dietmar Wien
Antwortento top
#8
Hallo,

mit der zweiten Funktion von Jörg/Jockel hat es wunderbar geklappt, vielen Dank dafür!
Die Antwort von Klaus-Dieter erschließt sich mir ehrlich gesagt nicht so ganz, ist das die Art von Excell die vertrichenen Tage seit 1900 zu berechnen oder was sind das für Ergebnisse die du da hast?

Es hat jedenfalls geklappt, ich danke euch allen für die Hilfe.

Viele Grüße,

Dietmar
Antwortento top
#9
K-D hat einfach die Typen auf TEXT angepasst. Datum sieht vielleicht wie Datum aus, aber ist es noch lange nicht automatisch in jedem Fall, wie er uns hier vorgelegt wird.
Antwortento top
#10
Hallo,

war nur das falsche Zellformat. So ist es richtig:

Tabelle1

ABC
110
2Sales
3Umsatz Cu 150
4KalendertagEUR
5Ergebnis17.893.657
601.10.2019754.330666.894
702.10.2019584.395927.466
803.10.2019445.817
904.10.2019921.011194.558
1007.10.2019123.655
1108.10.2019555.924987.345
1209.10.2019111.935273.456
Formeln der Tabelle
ZelleFormel
C6=WENNFEHLER(SVERWEIS(DATUM(JAHR(A6)-1;MONAT(A6);TAG(A6));'2019'!$A$5:$B$10;2;FALSCH);"")
C7=WENNFEHLER(SVERWEIS(DATUM(JAHR(A7)-1;MONAT(A7);TAG(A7));'2019'!$A$5:$B$10;2;FALSCH);"")
C8=WENNFEHLER(SVERWEIS(DATUM(JAHR(A8)-1;MONAT(A8);TAG(A8));'2019'!$A$5:$B$10;2;FALSCH);"")
C9=WENNFEHLER(SVERWEIS(DATUM(JAHR(A9)-1;MONAT(A9);TAG(A9));'2019'!$A$5:$B$10;2;FALSCH);"")
C10=WENNFEHLER(SVERWEIS(DATUM(JAHR(A10)-1;MONAT(A10);TAG(A10));'2019'!$A$5:$B$10;2;FALSCH);"")
C11=WENNFEHLER(SVERWEIS(DATUM(JAHR(A11)-1;MONAT(A11);TAG(A11));'2019'!$A$5:$B$10;2;FALSCH);"")
C12=WENNFEHLER(SVERWEIS(DATUM(JAHR(A12)-1;MONAT(A12);TAG(A12));'2019'!$A$5:$B$10;2;FALSCH);"")

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
[-] Folgende(r) 1 Benutzer sagt Danke an Klaus-Dieter für diesen Beitrag:
  • Dietmar Wien
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste