Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

SVERWEIS Spalte "allgemein" durchsuchen
#1
Hallo zusammen,

ich komme nicht weiter mit einer Formel.

Folgender Sachverhalt:
Ich möchte nachschauen, ob die Verbindung aus Name und Kundennummer in einer anderen Liste vorkommt, falls nicht, soll die Zelle "Spielzeug" "Nein" anzeigen, falls sie aber vorkommt, soll sie Ja anzeigen, unter der Bedingung, dass in der Spalte "Artikel" das Wort "Puppe" steht. Falls dort ein anderer Artikel steht, soll sie "Nein" anzeigen. 

Hierzu nutze ich nun folgende Formel: 

=WENN(ISTNV(SVERWEIS(TEXTKETTE(B2;A2);GekaufteArtikel!A$1:D$6;1;0));"NEIN";WENN(SVERWEIS(TEXTKETTE(B2;A2);GekaufteArtikel!A$1:D$4;4;0)="Puppe";"JA";"NEIN"))

Nun ist mein Problem, dass der sVerweis die Spalte von oben nach unten durchsucht, und wenn der erste Wert nicht "Puppe" ist, nicht mehr weiter sucht. Allerdings ist es in meiner Liste der Fall, dass Horst mehrere Artikel kauft, zuerst ein Spülmittel und dann eine Puppe. Meine Formel zeigt also "Nein" an, obwohl Horst eine Puppe kauft.

Meine Frage nun ist, ob es eine Möglichkeit gibt, den sVerweis "allgemein" die Spalte durchsuchen zu lassen, anstatt nur von oben und nach unten. 


'Spielzeug'
   
[ Bild bitte als Datei hochladen! ]   

'GekaufteArtikel'         
   
[ Bild bitte als Datei hochladen! ]

Danke und viele Grüße
Antwortento top
#2
Moin

Verwende ZÄHLENWENNS().
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
[-] Folgende(r) 1 Benutzer sagt Danke an shift-del für diesen Beitrag:
  • VV123
Antwortento top
#3
Danke für die schnelle Antwort!


Angehängte Dateien Thumbnail(s)
   
Antwortento top
#4
Hola,

Zählenwenns() wurde vorgeschlagen, nicht Zählenwenn()!

Zählenwenns() kann immer nur eine Spalte verarbeiten.
Code:
=zählenwenns(Bereich1;Kriterium1;Bereich2;Kriterium2)
Da kannst du nicht mit Concate arbeiten.

Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • VV123
Antwortento top
#5
Hallo,
du hast die Antwort von shift-del nicht richtig gelesen.

"Zählenwenns" benutzen, nicht "Zählenwenn".

Das ist hier kein Photoshop-Forum. Daher bitte Beispieldateien und keine Bilder hochladen.
Cadmus
Antwortento top
#6
Sorry, mein Fehler.

Ich verwende nun folgende Formel:
Code:
=ZÄHLENWENNS(GekaufteArtikel!A$1:D$6;TEXTKETTE(B2;A2); GekaufteArtikel!A$1:D$6; "Puppe")>0

Verwende ich nur die erste Bedingung, funktioniert es. Wenn es jetzt allerdings noch nach "Puppe" suchen soll, funktioniert es nicht mehr.


.xlsx   Beispiel Datei.xlsx (Größe: 17,8 KB / Downloads: 2)
Antwortento top
#7
Hola,

nochmal: Zählenwenns() kann immer nur eine Spalte verarbeiten!


Code:
=ZÄHLENWENNS(GekaufteArtikel!$B$2:$B$6;A2;GekaufteArtikel!$C$2:$C$6;B2;GekaufteArtikel!$D$2:$D$6;"puppe")>0

Gruß,
steve1da
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste