Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

SUMMEWENNS oder SUMMENPRODUKT mit Datumstext im KriterienBereich
#1
Bitte um Hilfe bei meinem ersten Post eines Excel Problems.

Ich importiere von einer Quelle eine Tabelle und möchte daraus in einer weiteren Tabelle Summen der Umsätze nach zwei Kriterien berechnen, als da wären Artikelnr. und Datum.
Mein Problem ist, dass die Datumsangaben in Excel im Format "Text" sind und meine Funktionen SUMMEWENNS oder SUMMENPRODUKT im Kriterienbereich, diese nicht korrekt einbeziehen können (Dazu siehe Bild1 wie das Ergebnis sein sollte und Bild2 und Bild 3).

Somit habe ich versucht innerhalb der Funktion, den Kriterienbereich in DATWERT() zusetzen, worauf in der Funktionsvorschau dann die Datumsangaben wie gewünscht als Zahl berücksichtig werden (Dazu Bild 4) aber bei bestätigen der Funktion, erhalte ich die Fehlermeldung, dass es sich so um keine Formel handelt (Bild 5). Auch wenn ich nachträglich die Datumsfelder der Quelle als Datum formatiere hilft es nicht, dass diese in der Funktion korrekt berücksichtigt werden.

Die Quelle möchte ich möglichst nicht erst bearbeiten müssen, da diese zukünftig täglich automatisiert importiert werden soll.

Wo liegt mein Denkfehler?

Danke vorab und Grüße

Smudo

Bild 1
   
Bild 2
   
Bild 3
   
Bild 4
   
Bild 5
   
Antwortento top
#2
Hi

Versuch es mal so.
=SUMMENPRODUKT(B2:B8*(A2:A8=F1)*(DATWERT(C2:C8)>=F2))
oder
=SUMMENPRODUKT(B2:B8*(A2:A8=F1)*(1*C2:C8>=F2))

Gruß Elex
Antwortento top
#3
Hola,

eine Excel-Beispieldatei wäre hilfreich.

Gruß,
steve1da
Antwortento top
#4
Sorry steve1da und eine Bespieldatei nun auch in der Anlage.

.xlsx   ExcelBeispielDatei.xlsx (Größe: 10,55 KB / Downloads: 2)

Der Tipp von Elex scheint aber auch schon zu funktionieren und versuche den nun mal auf die finale Exceldatei anzuwenden.

Danke für Eure Unterstützung.

Grüße

Smudo
Antwortento top
#5
Hi,

Spalte mit dem Datum markieren, Daten, Text in Spalten, ENTER und die Werte sind in Zahlen umgewandelt. Damit funktioniert Deine Formel.
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste