Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

SUMMENPRODUKT WENN Text als Kriterium
#1
Hallo zusammen,

ich habe hier die Formel benutz um den Anteilswert herauszubekommen. 
Formel: =SUMMENPRODUKT(B5:B1392;C5:C1392)/SUMME(C5:C1392)
Wie man im Anhang sehen kann bezieht sich die Formel auf die Ganze Spalte.
Nun habe ich aber in der Spalte A zwei Kostenstelle die ich berücksichtigen möchte.  
Ich bekomme es leider nicht hin, das der Anteil der Kostenstelle dargestellt wir, außer ich teile die Kostenstellen in zwei Spalte was in der Original Tabelle leider nicht geht (Export Tabelle)

Danke und Gruß Jürgen


Angehängte Dateien
.xlsx   SUMMENPRODUKT nach Kerterium.xlsx (Größe: 38,1 KB / Downloads: 2)
Antwortento top
#2
Hola,


Code:
=SUMMENPRODUKT((B5:B1392*C5:C1392)*(A5:A1392=A2))/SUMME(C5:C1392)

Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • JürgenRa
Antwortento top
#3
Danke für die schnelle Antwort,

kannst du mir das auch erklären warum das so funktioniert.

Gruß
Jürgen
Antwortento top
#4
Hola,

"Summenprodukt multipliziert die Matrizen (wie immer Positionsbezogen) und summiert die Ergebnisse dieser Produkte"
Siehe auch:

https://www.online-excel.de/excel/singsel.php?f=53

Gruß,
steve1da
Antwortento top
#5
(20.10.2020, 08:35)JürgenRa schrieb: Danke für die schnelle Antwort,

kannst du mir das auch erklären warum das so funktioniert.

Gruß
Jürgen
 Ich habe die Daten getrennt um zu zeigen welche Werte ich benötige da ich bei der Selektierung ein anderes Ergebnis habe. 

Gruß Jürgen


Angehängte Dateien
.xlsx   SUMMENPRODUKT nach Kerterium.xlsx (Größe: 86,6 KB / Downloads: 4)
Antwortento top
#6
Hola,

sorry, ich hab die Bedingung nicht bei der Summe() berücksichtigt.

Code:
=SUMMENPRODUKT((B5:B1392*C5:C1392)*(A5:A1392=A2))/SUMMEWENN(A5:A1392;A2;C5:C1392)

Gruß,
steve1da
Antwortento top
#7
(20.10.2020, 08:51)steve1da schrieb: Hola,

sorry, ich hab die Bedingung nicht bei der Summe() berücksichtigt.

Code:
=SUMMENPRODUKT((B5:B1392*C5:C1392)*(A5:A1392=A2))/SUMMEWENN(A5:A1392;A2;C5:C1392)

Gruß,
steve1da
 Passt  17 Danke 

Ich hab Sie nur noch nicht zu 100% verstanden.(B5:B1392*C5:C1392) ist wie in meiner Formel Array 1 und 2 , A5:A1392=A2) das Kriterium , Teile durch nach Kriterium 
Ist das soweit richtig gedacht 
Antwortento top
#8
Ja, richtig gedacht.
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • JürgenRa
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste