Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Nur sichtbares nach Bedingung summieren & Formel bei neuer Zeile aktuallisieren
#1
Hallo Leute,

ich habe folgende Problemstellung.

In einer Tabelle gibt es nach Datum (Spalte A) eingetragene Einnahmen (Spalte C), entweder aus der Kategorie X oder aus Y (Spalte B).
Unterhalb zeige ich mir per Formel jeweils die Gesamteinnahmen von X und die Gesamteinnahmen von Y an. Auch sollen nur die sichtbaren Werte summiert werden, um bei einem aktiven Filter auch nur diese Gesamtwerte zu sehen.

Bisher habe ich das mit folgender Formel umgesetzt (siehe auch Screenshot):
=SUMMENPRODUKT(TEILERGEBNIS(3;INDIREKT("C"&ZEILE(2:7)))*(B2:B7="x")*(C2:C7))

   

Logischerweise muss ich bei einer neu hinzugefügten Zeile die Formel manuell wieder anpassen. Gibt es eine Möglichkeit, die Formel automatisch anpassen zu lassen, wenn neue Zeilen hinzugefüht werden? Bei einer einfachen Summenrechnung habe ich INDEX gefunden: Formelbezüge in Excel automatisch an erweiterte Bereiche anpassen

Leider bin ich grade völlig überfragt, wie ich das in meine Formel integriere...

Vielen danke euch!
LG Yannik
Antwortento top
#2
Moin

Formatiere die Liste als Excel-Tabelle und schalte die Ergebniszeile ein.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#3
zur Info
https://www.ms-office-forum.net/forum/sh...p?t=368430
Cadmus
[-] Folgende(r) 1 Benutzer sagt Danke an Cadmus für diesen Beitrag:
  • piwo91
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste