Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Nach Alter und Geschlecht zuordnen
#1
Hallo ,

in der beigefügten Tabelle soll anhand des Geschlechts und des Alters die jeweilige Zugehörigkeit zu einer Altersklasse ermittelt werden. Dabei soll mit der WENN - Funktion und vermutlich dem WVERWEIS gearbeitet werden. Ich bekomme aber die richtige Formel nicht zusammen. Wer kann helfen ?
HINWEIS : Es handelt sich nicht um eine Hausaufgabe sondern um einen Teil einer freiwilligen Selbstlernaufgabensammlung !

Vielen Dank für eure Hilfe !


Angehängte Dateien
.xlsx   Jugendklasse.xlsx (Größe: 11,62 KB / Downloads: 11)
Antwortento top
#2
Wenn Du Deine Zuordnungstabelle senkrecht aufbaust (Überschrift 'Geschlecht in Zelle I4)

mit den Spalten
Geschlecht / Von / Bis / Altersklasse
w / 4 / 7 / F-Jugend
usw

dann probier mal folgende Formel in F5
=INDEX($L$5:$L$18;SUMMENPRODUKT(($I$5:$I$18=C5)*($J$5:$J$18<=E5));1)
Gruss Ralf
Antwortento top
#3
Moin

Eine andere Variante ohne WENN() und WVERWEIS().
Arbeitsblatt mit dem Namen 'Tabelle1 (2)'
ABCDEFGHIJK
1Einteilung der Jugend
2Stichtag:31.07.2017
3
4NameVornameGeschlechtGeboren amAlterAltersklasseGeschlechtAlter vonAlter bisAltersklasse
5MüllerChristianm31.12.200115B-Jugendw47F-Jugend
6AndersKathrinw01.01.200413C-Jugendw89E-Jugend
7IsokeitNataschaw31.12.200412C-Jugendw1011D-Jugend
8SchubertHolgerm22.08.199719A-Jugendw1213C-Jugend
9HaumannRamonaw01.03.20089E-Jugendw1416B-Jugend
10MunschManfredm01.03.199819A-Jugendw1719A-Jugend
11w2022Junioren
12m47F-Jugend
13m810E-Jugend
14m1112D-Jugend
15m1314C-Jugend
16m1517B-Jugend
17m1819A-Jugend
18m2022Junioren

ZelleFormel
E5=DATEDIF(D5;$B$2;"Y")
F5=FILTER($K$5:$K$18;($H$5:$H$18=C5)*($I$5:$I$18<=E5)*($J$5:$J$18>=E5))
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#4
Ich dachte eher so in die Richtung WENN männlich dann anhand des Alters aus Bereich der Tabelle Männlich suchen und wenn nicht männlich dann in Bereich Weiblich suchen und Altersklasse ausgeben ... Aber ich bekomme das nicht zusammen.
Antwortento top
#5
Hola,

dann hast du die Vorschläge gar nicht erst ausprobiert?

=wenn(C5="m";Wverweis1;Wverweis2)

Beim Wverweis musst du den 4 Parameter auf WAHR setzen.

Gruß,
steve1da
Antwortento top
#6
...oder beim WVERWEIS die Suchmatrix mithilfe von WENN abhängig vom Geschlecht bestimmen, also so:

=WVERWEIS(Suchkriterium;WENN(C5="w";Suchmatrix1;Suchmatrix2);Zeilenindex;1)

Gruß
Fred
Antwortento top
#7
Danke für eure Antworten. Die Vorgabe war eben die WENN Funktion ....
Kann mir das jemand mal für meine Tabelle fertig aufschreiben ? Bei mir passt da was nicht.
LG und Danke
Antwortento top
#8
Hola,

wie sieht denn dein Versuch aus? Du willst ja etwas lernen.
"Da passt was nicht" ist nicht wirklich hilfreich....

Gruß,
steve1da
Antwortento top
#9
Da passt wahrscheinlich extrem viel nicht Smile Ich bin halt blutiger Anfänger und es ist sehr mühsam, sich die richtigen Infos zusammenzusuchen. Ich habe folgendes : =WENN(C5="m";WVERWEIS(E5;I6:P8;9;1);WVERWEIS(E5;I2:P4;5;1))
Antwortento top
#10
Hola,

an Stelle der 9 und 5 in der Formel gehört da jeweils eine 3 rein.

Gruß,
steve1da
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste