Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Mittelwert ohne Werte außerhalb +/- 2SD, Excel Mac
#1
Hallo,

ich habe das Problem versucht ohne VBA anzugehen, da ich von VBA nur seehr rudimentäre Dinge weiß. Aber es wird ohne wohl nicht klappen:
Ich habe folgende Datensätze. Z.B A1:A100 Daten (Zahlen). Dasselbe in B und C,... In A102 brauche ich als output den Mittelwert der Datewnreihe, allerdings ohne alle Outliere, die außerhalb von + oder - 2 Standardabweichungen liegen. Manuell habe ich bisher den Filter mit conditional formatting angewendet und dann manuell die entsprechenden Zellen gelöscht und anschließehnd den Mittelwert berechnet. Geht aber bei der Menge an Daten nicht mehr. Gibt es eine einfachen Code mittels VBA der das macht und den ich ohne viel Kentnisse ins Spreadsheet implementieren kann? Es ist mir einerlei ob ich die outliere noch sehe oder ob sie komplett gelöscht werden.
Vielen Dank!
Hoogie
Antwortento top
#2
Hallo Hoogie,

ab Excel 2019 gibt es die Funktion MITTELWERTWENNS.

In älteren Versionen ginge es zB. mit SUMMENPRODUKT(...)/SUMMENPRODUKT(...).
helmut

Für mich ist die Möglichkeit in Excel an Zellen und Bereichen Namen zu vergeben die wichtigste Funktionalität.
Sie macht Formeln und den VBA-code verständlicher. Für Makros gilt die Regel: "Nur über benannte Bereiche auf den Inhalt der Zellen zugreifen."
Und wofür sind Regeln da? Um nachzudenken bevor man sie bricht.





Antwortento top
#3
Hola,

eine Excel-Beispieldatei wäre hilfreich.

Gruß,
steve1da
Antwortento top
#4
=MITTELWERT(WENN(ABS(A1:A100-MITTELWERT(A1:A100))<=STABW(A1:A100)*1;A1:A100))
=MITTELWERT(WENN(ABS(A1:A100-MITTELWERT(A1:A100))<=STABW(A1:A100)*2;A1:A100))

in älteren Excels als {}!
Antwortento top
#5
Hallo
und vielen Dank für die ANtworten.

@steve1da: Ich versuche mal eine vereinfachte Excel Datei anzuhängen. Im Prinzip geht es einfach um 100 Zahlenwerte. Später natürlich auch in anderen Konstellationen.

@LCohen: Danke für die Formeln. Bekomme allerdings Fehlermeldungen?! Angehängt meine Datei.

Danke und Gruß
hoogie


Angehängte Dateien
.xlsx   beispiel1.xlsx (Größe: 20,96 KB / Downloads: 3)
Antwortento top
#6
Hallöchen,

so kommt sie bei Dir hoffentlich nicht:

Arbeitsblatt mit dem Namen 'beispiel1'
A
1020,10363087

ZelleFormel
A102{=MITTELWERT(WENN(ABS(A1:A100-MITTELWERT(A1:A100))<=STABW(A1:A100)*2;A1:A100))}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#7
Nun klappt es endlich.
Vielen Dank an alle!
Gruß
Hoogie
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste