Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Mehrere/Verschachtelte Prüfungen (Wenn/Dann?!)
#1
Hallo zusammen,

anbei eine Datei, wo eine beispielhafte Tabelle zu sehen ist und einige Hinweise zu der Herausforderung hinterlegt sind.

Hier kurz das Wichtigste:
In der Spalte E soll eine Formel hinterlegt werden, die mehrere Prüfungen für die Spalten A-D durchführen soll --> Liegt eine Index-Erhöhung vor oder nicht oder ist es unklar (Ausgabe nach Prüfungen von "Ja", "Nein" oder "?").
In Spalte G ist eine Erklärung gegeben, wie man auf das Ergebnis in Spalte E kommt.
Es gibt alte Sachnummern, die in der Regel auch einen Index haben (Spalte A und B). Dann gibt es zukünftig neue Sachnummern mit entsprechendem Index. Die neuen Sachnummern und Index können aber gleich bleiben oder sich verändern.
Eine Index-Erhöhung liegt nur vor, wenn alle Sachnummern, die in einer Zelle vorkommen von "alt" zu "neu" gleich bleiben, aber der/die Index sich von "alt" zu "neu" verändert (also es wird immer zeilenweise betrachtet).
--> Sachnummer schlägt somit Index (verändert sich von "alt" zu "neu" auch nur mindestens eine Sachnummer, dann liegt keine Index-Erhöhung vor (auch wenn Index sich auch erhöht/verändert).

In der Tabelle sind mehrere Konstellationen hinterlegt.

Bei Rückfragen gerne melden!

Vielen Dank vorab!


Angehängte Dateien
.xlsx   Formel_AI-Erhöhung.xlsx (Größe: 12,05 KB / Downloads: 7)
Antwortento top
#2
Hola,

hast du evtl vergessen eine Datei hochzuladen?

Gruß,
steve1da
Antwortento top
#3
Ist jetzt hochgeladen Wink
Antwortento top
#4
Gibt es da noch Unklarheiten bzw. Rückfragen?
Ist das vielleicht besser über VBA zu lösen?
Antwortento top
#5
Hallöchen,

also, ich hab jetzt mal noch nicht in die Datei geschaut. Deiner Beschreibung nach könnte es in diese Richtung gehen - vorausgesetzt, Du prüfst zeilenweise. Ich habe hier die Annahme, dass in A und C die Sachnummern stehen und in B und D die Indexe. Lässt sich simpel anpassen.

Zitat:Eine Index-Erhöhung liegt nur vor, wenn alle Sachnummern, die in einer Zelle vorkommen von "alt" zu "neu" gleich bleiben, aber der/die Index sich von "alt" zu "neu" verändert (also es wird immer zeilenweise betrachtet).
=WENN(UND(A1=C1;B1<>D1;"Ja";...

Zitat:--> Sachnummer schlägt somit Index (verändert sich von "alt" zu "neu" auch nur mindestens eine Sachnummer, dann liegt keine Index-Erhöhung vor (auch wenn Index sich auch erhöht/verändert).
...WENN(A1<>C1;"Nein";"?")

bzw. dann zusammen
=WENN(UND(A1=C1;B1<>D1;"Ja";WENN(A1<>C1;"Nein";"?")
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#6
Hallo,

Formel in E2:
=WENN(A2<>C2;"Nein";WENN(D2="";"?";WENN(B2=D2;"Nein";"Ja")))

Gruß
Fred
Antwortento top
#7
Dankeee, das dürfte es gewesen sein Wink
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste