Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Liste von Daten nach Mehfachabfrage
#1
Moin aus Hamburg 43

Für eine Zeiterfassung benötige ich eine Formel für folgende Aufgabe:

Siehe Attachment.

Nach Eingabe der Eckdaten (Y7 bis Y9) sollen nun nach Abfrage die Namen
aus dem Register "Mitarbeiter" in die Zellen von A6 bis A25 eingetragen werden.

Geht das auch ohne Makro bzw. VBA?

Sollte jemand eine noch bessere Lösung haben, dann bitte her damit.
Das Ziel soll werden, dass am Ende der Woche die Abrechnung in ein Register als Tabelle eingefügt wird.

Vielen, lieben Dank...ich liebe dieses "Linux"-Prinzip bei dem sich alle gegenseitig helfen!

MiSha 21


Angehängte Dateien
.xlsx   Clever Excel Forum - Formular.xlsx (Größe: 29,11 KB / Downloads: 11)
Antwortento top
#2
Hola,


Code:
=WENNFEHLER(INDEX(Mitarbeiter!$D$2:$D$23;AGGREGAT(15;6;ZEILE(Mitarbeiter!$D$2:$D$23)-1/((Mitarbeiter!$F$2:$F$23=$Y$7)*(Mitarbeiter!E2:E23=$Y$8));ZEILE(A1)));"")

Gruß,
steve1da
Antwortento top
#3
Fantastisch....




...bis auf einen kleinen Fehler im letzten Array (die Dollarzeichen fehlen) ist das echt geil!





Dieser Befehl (AGGREGAT) ist schon was Feines, allerdings noch etwas zu hoch für mich. ;o)



Jedenfalls, danke Dir und I'LL BE BACK!
Antwortento top
#4
Hallo,

Danke für diese schöne Lösung.

Gruß Rudi
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste