Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Limit bei Datenüberprüfung?
#1
Liebes Excelteam,

kann es sein, dass es ein Zeichenlimit bei der Datenüberprüfung gibt? Ich würde gerne ein von einem Feld abhängiges Dropdown erstellen. Die Formel welche ich in die Datenüberprüfung einfügen wollte ist diese, sie scheint aber zu gross zu sein:

=WENN($I$5="FIRMA";BE!A17:A62;WENN($I$5="PRÄS";BE!A63:A82;WENN($I$5="KOM";BE!A83:A97;WENN($I$5="RMW";BE!A98:A112;WENN($I$5="RKE";BE!A113:A127;WENN($I$5="RSD";BE!A128:A142;WENN($I$5="RKN";BE!A143:A157;WENN($I$5="RIF";BE!A158:A172;WENN($I$5="RNQ";BE!A173:A187;WENN($I$5="VS";BE!A188:A202;WENN($I$5="SEK";BE!A203:A217;)))))))))))

Falls ja, gibt es eine andere Möglichkeit diesen Code zu schreiben? Ich denke ich hab es ein wenig aufwendig gemacht.

Ich verwende eine recht aktuelle Version von Excel (16.0.11929.20838) und habe das File als .xlsx gespeichert, aber wie ich mit einem neuen Dokument festgestellt habe, macht es auch keinen Unterschied ob man Makro, oder eine andere Dateiversion benutzt.
Antwortento top
#2
Hallo,


Zitat:Ich würde gerne ein von einem Feld abhängiges Dropdown erstellen.
benutze mal unsere SuFu mit den Stichworten dynamische Dropdown und abhängige Dropdown. Das Thema wurde schon einige Male bearbeitet. Auch in unserem Beispielbereich findest du etwas.
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • gadgetsz
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste