Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Letze Zahl(en) nach dem letzten Punkt
#1
Guten Morgen,

ich habe folgende Herausforderung zu lösen.
Ich habe eine Spalte mit Level angaben wie z.b.
A1: 1
A2: 1.1
A3: 1.1.2
A4: 1.1.3
A5: 1.2.1
A6: 1.2.1.1
A7: 1.2.1.1.1
A8: 1.2.1.1.2
...
A20: 1.2.1.1.24
etc.

Nun möchte ich in der Spalte B beispielsweise immer nur die Zahl(en) nach dem letzten Punkt angezeigt bekommen.
Also in A4 beispielsweise die "3" oder in A20 beispielsweise die "24". 

Wie kann ich das lösen?

Danke vorab.

Gruß, Juan
Antwortento top
#2
Hallo,

in VBA kann man sowohl "von Rechts" suchen als auch

Code:
Tx = split(cells(i,1), ".")
Endziffer = TX(ubound(Tx))

mfg
Antwortento top
#3
Hola,


Code:
=WENNFEHLER(RECHTS(A1;VERGLEICH(".";LINKS(RECHTS(A1;SPALTE($1:$1));1);0)-1);A1)

Gruß,
steve1da
Antwortento top
#4
Hallo, 19

hier mit zwei Funktionen (UDFs): 21

.xlsb   REGEXP_und_Split_letzte_Zahl_aus_String_auslesen_CEF.xlsb (Größe: 16,16 KB / Downloads: 3)

Wobei ich REGEXP immer - auf Grund der größeren Flexibilität - den Vorzug geben würde. Dodgy
________
Servus
Case
Antwortento top
#5
Ich vermute, dass die letzte Zahl an ihrer Stelle bleiben soll, damit die Hierarchie sichtbar bleibt. Alles andere ist unerträglich.

  • Vorherige Zahlen in weiß, oder
  • Vorherige Zahlen durch Leerzeichen oder Unterstriche ersetzen
Antwortento top
#6
Danke Steve1da, hat genau so funktioniert.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste