Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Kategorisierung anhand Keyword Matrix
#1
Hallo zusammen, dies ist mein erster Beitrag in diesem Forum.

Ausgangslage: 
Ich habe eine Excel-Liste "Journal" welches Buchungen enthält mit den Spalten "Datum", "Buchungstext, "Konto soll". Ich muss nun für tausende solcher Buchungen anhand des Textes (zb. "Einkauf Aldi") das entsprechende Konto in der Spalte "Konto soll" hinzufügen (also z.B 201 für das Konto "Haushalt"). Es gibt viele ähnliche Buchungstexte, welche sich dem gleichen Konto zugewiesen werden können. 

Idee:
Jetzt habe ich mir gedacht, dass lässt sich doch irgendwie im Excel wenigstens teilweise Automatisieren. Ich könnte nun eine zweite Tabelle mit einem Keyword Mapping anlegen. Darin steht in einer Spalte das Schlüsselwort z.B. Aldi und das entsprechende Konto 201. Das Konto 201 soll auf jeder Zeile des Journals eingefügt werden, in der beim Buchungstext irgendwo "Aldi" vorkommt. Mit SVERWEIS habe ich's irgendwie nicht hingekriegt.

=> Siehe Anhang als beispiel: Die Spalte C auf dem Blatt "Journal" sollte automatisch anhand der Kategorisierung auf dem Blatt "Keywords" befüllt werden.

Hat da grad jemand eine "einfache" Lösung dazu?

Vielen Dank im Voraus!

Gruss

Liceo
Antwortento top
#2
Hi,

der Anhang fehlt noch; vermutlich hast du vergessen, rechts den Button "Attachment hinzufügen" anzuklicken.
Gruß Günter
Jeder Fehler erscheint unglaublich dumm,
wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#3
Hallöchen,

hier mal das Prinzip. Gerne werden beim Bereich die $ vergessen, was dann beim Ziehen der Formel zu Problemen führt. Ist sicher bei Dir der Fall ...

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDE
1Aldi201Aldi201
2Oldi202Oldi202
3Indi203Indi203
4Oldi202
5Aldi201

ZelleFormel
E1=SVERWEIS(D1;$A$1:$B$3;2;FALSCH)
E2=SVERWEIS(D2;$A$1:$B$3;2;FALSCH)
E3=SVERWEIS(D3;$A$1:$B$3;2;FALSCH)
E4=SVERWEIS(D4;$A$1:$B$3;2;FALSCH)
E5=SVERWEIS(D5;$A$1:$B$3;2;FALSCH)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.1) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#4
Hi,

ich glaube, du meinst so etwas: https://www.clever-excel-forum.de/Thread...#pid170080.
Gruß Günter
Jeder Fehler erscheint unglaublich dumm,
wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#5
Hi Günter,

… und welchen von den 1520 Treffern meinst Du? Smile
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#6
Sorry, hier noch der Anhang. Da ist aber unspektakulär wenig drin...


.xlsx   Beispiel Journal.xlsx (Größe: 9,65 KB / Downloads: 4)
Antwortento top
#7
(20.08.2019, 20:41)schauan schrieb: Hi Günter,

… und welchen von den 1520 Treffern meinst Du? Smile

Brille: Fielmann
Gruß Günter
Jeder Fehler erscheint unglaublich dumm,
wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#8
Hi,

in Journal!D2 folgende ARRAY(!)formel:

{=INDEX(Keywords!B:B;MIN(WENN(ISTZAHL(SUCHEN(Keywords!$A$2:$A$100;Journal!B2));ZEILE($2:$100))))}

und runterkopieren.

VG, Boris
Antwortento top
#9
(20.08.2019, 20:56)Liceo schrieb: Sorry, hier noch der Anhang. Da ist aber unspektakulär wenig drin...

Hast du dir mal den Link angesehen?
Gruß Günter
Jeder Fehler erscheint unglaublich dumm,
wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#10
... Von Fielmann war da aber nichts dabei...
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste