Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

INDIREKT und BEREICH.VERSCHEBEN
#1
Hallo,

ich habe in meiner Excel-Mappe dynamische Namen mit Hilfe von BEREICH.VERSCHIEBEN definiert. In der Zelle A1 habe ich eine Auswahlliste mit den Namen angelegt. Ich möchte nun per SVERWEIS auf den ausgewählten Namen zugreifen: SVERWEIS("Rating 1a";INDIREKT(A1);2;0). Leider bekomme ich einen Fehler #BEZUG.

Geht der Zugriff generell nicht? Wenn ich die Namen nicht per BEREICH.VERSCHIEBEN definiere, dann funktioniert die SVERWEIS-Formel.

Vielen Dank
Gruß
Robert


Angehängte Dateien
.xlsx   TEST.xlsx (Größe: 9,86 KB / Downloads: 7)
Antwortento top
#2
Hallo
die Formel sollte funktionieren ....
Stimmt der Name deiner Liste mit dem Inhalte von A1 exakt überein? (vielleicht falsche Leerzeichen vorhanden?)
Gibt es das (exakte) Suchkriterium  "Rating 1a" in der Liste?

Gruß Holger
Antwortento top
#3
Hola,

siehe auch...

https://www.herber.de/forum/messages/1764607.html

Gruß,
steve1da
Antwortento top
#4
Ich habe eine Datei angehängt....
Antwortento top
#5
hallo
der (Bereich)-Name für die Formel soll in F6 stehen: Auswertung1
in der Namen-Liste links oben gibt es den Namen "Auswertung1" nicht. Der muss definiert werden.
https://www.online-excel.de/excel/singsel.php?f=60

Gruß Holger
Antwortento top
#6
Der Name ist definiert und ich greife jetzt im SVERWEIS anstatt auf A1 auf F6. Ich vermute, dass aufgrund der Komplexität INDIREKT nicht mit Namen funktioniert, die mit Bereich.verschieben angelegt wurden.

(10.06.2020, 08:13)echo schrieb: hallo
der (Bereich)-Name für die Formel soll in F6 stehen: Auswertung1
in der Namen-Liste links oben gibt es den Namen "Auswertung1" nicht. Der muss definiert werden.
https://www.online-excel.de/excel/singsel.php?f=60

Gruß Holger

Hallo Holger,

Nemen, die per Bereich.verschieben definiert wurden, erscheinen nie in der Namen-Liste oben oberhalb von A1.

Gruß
Robert
Antwortento top
#7
Danke auch für das Ignorieren im Herber-Forum. Immer schön mit Profis zu arbeiten....
Antwortento top
#8
Hallo,

wenn Du die Bereich.Verschieben-Formel direkt in den Sverweis setzt, dann geht es.

weniger volatil wäre das:

Code:
=SVERWEIS(A4;INDEX(INPUT!$1:$1048576;1+Tabelle2!$F$3;1):INDEX(INPUT!$1:$1048576;1+Tabelle2!$F$5;Tabelle2!$F$4+1+Tabelle2!$F$3);2;0)
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste