Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Hilfe bei Formel Wenn Dann mit Wennzählen
#1
Servus Zusammen,

Ich bräuchte mal Hilfe bei einer Formel.

Ich möchte in einer Zeile immer wieder den Buchstaben Ü setzen. Ü bedeutet für mich Überstunde/n. Nur soll das Ü in einigen Zellen für 8,6h und in einigen Zellen 5,6h stehen. Um genau zu sein wäre jedes 5. Ü (falls man es Setzt) immer der Freitag einer Woche der mit 5,6h berechnet werden soll und die Anderen Wären jeweils Montag bis Donnerstag mit 8,6h. Am Ende der Zeile möchte ich gerne die genommenen Überstunden zusammen rechnen. Es wäre noch anzumerken das ich mal von Montag bis Donnerstag Anfange zu Zähle und mal an einem Freitag, je nachdem wie der Jahresanfang fällt.

Finde hier bis jetzt keine Lösung und hoffe Ihr könnt mir helfen.

Danke schon mal für eure Antworten.
Antwortento top
#2
Hola,

das heißt es gibt dazu auch immer Wochentag die über oder unter den Zellen stehen?
Lade bitte eine Beispieldatei hoch (kein Bild).

Gruß,
steve1da
Antwortento top
#3
Servus, Danke erstmal für die Antwort.

Leider kann ich das Tool zum Einfügen der Datei nicht verwenden da bei mir die Downloads gesperrt sind.

In der Zeile oben drüber sind die Kalenderwochen angegeben. Ich kann aber problemlos eine Zeile mit Wochentagen dazwischen noch einfügen wenn das Hilfreich ist. In den Zeilen unten drunter möchte ich dann die genannte Rechnung wieder verwenden für weitere Mitarbeiter.

VG
Antwortento top
#4
Hola,

wenn z.B. in A2 bis Axyz Datumswerte stehen und in der Zelle darunter die Ü-Einträge, könnte man das mit folgender Formel ermitteln:
Code:
=SUMMENPRODUKT((WOCHENTAG(A2:P2;2)<5)*(A3:P3="ü"))*8,6+SUMMENPRODUKT((WOCHENTAG(A2:P2;2)=5)*(A3:P3="ü"))*5,6

Die Bereiche musst du natürlich anpassen.

Gruß,
steve1da
Antwortento top
#5
Hin Schmucky,

dann lad bitte eine Beispieldatei (.xlsx) hoch. Der Aufbau muss deinem Original gleichen - solltest du sensible Daten haben, dann anonymisiere sie bitte. so geht's: https://www.clever-excel-forum.de/Thread...ng-stellen
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#6
Servus,

Ich denke das deine Formel richtig ist. Habe die Werte angepasst. Leider Zeigt er mir nur "WERT" an. Ich denke der Fehler liegt noch darin das bei mir in deiner Angegeben Zeile A2:P2 nicht die Datumswerte drin stehen so nur MDMDF, diese Wiederholen sich bis zum Ende. Steht für Montag Dienstag Mittwoch Donnerstag Freitag. Ein Datum kann ich hier nicht einsetzen da meine Zelle nur 1,14 breit ist und sonst die Tabelle zu unübersichtlich wird.

Vielleicht hast du ja noch eine Idee wie man das noch machen könnte.

Anbei die Exel Datei. Hoffe ihr könnt sie öffnen. Habe die Grunddaten entfernt.


Angehängte Dateien
.xlsx   Mappe5.xlsx (Größe: 32,87 KB / Downloads: 7)
Antwortento top
#7
Hola,

Code:
=SUMMENPRODUKT(($L$4:$JM$4<>"f")*(L5:JM5="Ü"))*8,6+SUMMENPRODUKT(($L$4:$JM$4="f")*(L5:JM5="Ü"))*5,6

Aber glaub mir, irgendwann werdet ihr merken dass eine solche Übersicht ohne Datumswerte sondern nur mit Text Pain in the ass ist Wink

Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • Jockel
Antwortento top
#8
Hallo,

so etwas habe ich ja noch nie gesehen.
Chef fragt: "Wo ist denn der Mitarbeiter xyz am 13.02.2020?"
Was willst Du ohne Datum so schnell antworten? Erst einmal musst Du die KW ausrechnen. Warum baust Du kein Datum ein?

Januar

NOPQRS
12. KW2. KW2. KW3. KW3. KW3. KW
2101112131415
3FrSaSoMoDiMi
4
5
Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
N11. / Formel ist =TEXT(E2;"TTT")="Do"Abc
N12. / Formel ist =E$3="So"Abc
O11. / Formel ist =TEXT(E2;"TTT")="Do"Abc
O12. / Formel ist =E$3="So"Abc
P11. / Formel ist =TEXT(E2;"TTT")="Do"Abc
P12. / Formel ist =E$3="So"Abc
Q11. / Formel ist =TEXT(E2;"TTT")="Do"Abc
Q12. / Formel ist =E$3="So"Abc
R11. / Formel ist =TEXT(E2;"TTT")="Do"Abc
R12. / Formel ist =E$3="So"Abc
S11. / Formel ist =TEXT(E2;"TTT")="Do"Abc
S12. / Formel ist =E$3="So"Abc
N41. / Zellwert ist gleich ="F"Abc
N42. / Formel ist =UND(E2>=Datum1;E2<=Datum2)Abc
O41. / Zellwert ist gleich ="F"Abc
O42. / Formel ist =UND(E2>=Datum1;E2<=Datum2)Abc
P41. / Zellwert ist gleich ="F"Abc
P42. / Formel ist =UND(E2>=Datum1;E2<=Datum2)Abc
Q41. / Zellwert ist gleich ="F"Abc
Q42. / Formel ist =UND(E2>=Datum1;E2<=Datum2)Abc
R41. / Zellwert ist gleich ="F"Abc
R42. / Formel ist =UND(E2>=Datum1;E2<=Datum2)Abc
S41. / Zellwert ist gleich ="F"Abc
N51. / Formel ist =ODER(E$3="Sa";E$3="So")Abc
O51. / Formel ist =ODER(E$3="Sa";E$3="So")Abc
P51. / Formel ist =ODER(E$3="Sa";E$3="So")Abc
Q51. / Formel ist =ODER(E$3="Sa";E$3="So")Abc
R51. / Formel ist =ODER(E$3="Sa";E$3="So")Abc
S51. / Formel ist =ODER(E$3="Sa";E$3="So")Abc

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Gruß
Marcus

Ich arbeite mit Excel 2003 - Excel 2007 - Excel 365

Homepage im Aufbau (alte Daten müssen wieder hergestellt werden): http://ms-excel.eu

Wissen ist Macht - es ist aber nicht schlimm nicht alles zu wissen.
Man muss nicht alles wissen - man muss nur wissen wo es steht, oder wo man Hilfe bekommt.

Antwortento top
#9
Danke dir erstmal. Es Funktioniert. Ich denke das du recht haben wirst. Aber was soll ich sagen.....CHEFS halt. 19
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste