Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Häufikeit über zwei Spalten zählen - sortiert in einer Spalte ausgeben?
#1
Hallo an alle,

vielen Dank für Euro Mühe mir zu helfen, ich bin leider auf Excel nicht so bewandert. Ich möchte eine Stückliste erstellen und die
Einzelteile nach Größenbestandteile ausgeben.


Ich möchte später einfach nur "oben" die Größen & Anzahl eintragen, so dass die Ausgabe automatisch sortiert und zähl.

Danke für alle Tipps und sonstige Hilfe.

Klaus



Breite      Höhe    Anzahl

30           60            1
90           60            1



Wunschausgabe!


Größe     Anzahl
30              1
60              2
90              1
Antwortento top
#2
So?

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDEFG
1BreiteHöheAnzahlGrößeAnzahl
230601301
390601602
4901

ZelleFormel
G2=ZÄHLENWENN($A$2:B3;F2)
G3=ZÄHLENWENN($A$2:B4;F3)
G4=ZÄHLENWENN($A$2:B5;F4)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Eine Menge reden, aber nichts sagen können viele...
Antwortento top
#3
Hallo E...,

in der Anlage ein Lösungsvorschlag, falls quadratische Platten nur einmal gezählt werden sollen.


Angehängte Dateien
.xlsx   Anzahl2.xlsx (Größe: 9,63 KB / Downloads: 8)
helmut

Für mich ist die Möglichkeit in Excel an Zellen und Bereichen Namen zu vergeben die wichtigste Funktionalität.
Sie macht Formeln und den VBA-code verständlicher. Für Makros gilt die Regel: "Nur über benannte Bereiche auf den Inhalt der Zellen zugreifen."
Und wofür sind Regeln da? Um nachzudenken bevor man sie bricht.





[-] Folgende(r) 1 Benutzer sagt Danke an Ego für diesen Beitrag:
  • Emma-Der Hund
Antwortento top
#4
Lieber Helmut,

viele, vielen Dank, dass ist meine Lösung muss Sie noch umbauen, hätte es nie hinbekommen.

Klaus
Antwortento top
#5
Hallo,

bin schon viel weiter, hänge aber nun wieder am gleichen Problem an einer anderen Stelle, mein Sheet hat sich
schon stark erweitert.

Nun möchte ich die Werte sortiert aus nicht beieinander liegenden Spalten der Größe nach ausgeben, in Kombination der Anzahl, ich erhalte in
der Testspalte den wert NULL und das kann nicht sein.

=WENNFEHLER(AGGREGAT(14;6;($G$6:$G$30;$L$6:$L$30)/(($G$6:$G$30;$L$6:$L$30)
Mein Ziel ist es am Ende eine Größenaufstellung mit Anzahl aus vier Spalten in zwei Spalten Gesamt  zu erhalten:

Spalte G mit H, sowie L mit M soll werden O&P


Wo habe ich meinen Denkfehler, danke für die Tipps

Schönen Feiertag

Klaus

PS: Es handelt sich bei dem Sheet um Berechnung von umlaufenden Befestigungen, welche unterschiedlich verkürzt werden müssen, Basismaß z.B. 80 B x 60 H  Ergebnis für uns muss sein 70 B x 65 H daher die Umrechnung/Umformatierung - dies nur zur Info


Angehängte Dateien
.xlsx   Test Schnittliste.xlsx (Größe: 13,7 KB / Downloads: 2)
Antwortento top
#6
Hallo Klaus,

ich bin davon ausgegangen, dass in Deiner Formel O6 ein Schreibfehler vorliegt. Laut Deiner textl. Beschreibung müsste doch da =MAX(G3:G30;L3:L30) anstelle =MAX(G3:G30;J3:J30) stehen.

Dann in O7:

Code:
=WENNFEHLER(AGGREGAT(14;6;($G$6:$L$30)/($G$6:$L$30<O6)/($G$6:$L$30>0)/(G$4:L$4=G$4);1);0)


und diese nach unten kopieren.

Und dann in P6 z.B.
Code:
=WENN(O6>0;WENNFEHLER(SVERWEIS(O6;G:H;2;0);SVERWEIS(O6;L:M;2;0));"")

und nach unten kopieren.
Gruß Werner
.. , - ...
Antwortento top
#7
Dankeeeeeeeee WE gut gelungen mit Eurer Hilfe!!!!!!!!!!!!!!!!
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste