Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Gewichteter Mittelwert mit mehreren Bedingungen
#1
Hallo Zusammen,

ich habe ein kleines Problem und komme leider nicht weiter.

Und zwar habe ich zwei Bereiche, Schwarz und Weiß. Nun möchte ich einen gewichteten Mittelwert für die Anzahl der Bilder/MA/Minute, mit Bezug auf die Dauer und die Anzahl der Mitarbeiter für jeden der beiden Bereiche errechnen.

Die Datei hänge ich mit an.

Schon einmal vielen Dank im Voraus. Wink

tps9


Angehängte Dateien
.xlsx   Beispiel Clever Excel.xlsx (Größe: 11,95 KB / Downloads: 7)
Antwortento top
#2
Moin

MITTELWERTWENNS() oder Pivot.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#3
Hi shift-del,

danke erstmal für die Antwort.

Leider wird mir nur #DIV/0! angezeigt. könntest du mir vielleicht helfen die Formel zu schreiben?

Dankeschön.

VG

tps9
Antwortento top
#4
Statt 0 musst du A13 in die Formel einsetzen.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#5
Ich habe die Formel nun wie folgt aufgebaut:

=MITTELWERTWENNS(H2:H7;A2:A7;A13;D2:D7;A2:A7=A13;E2:E7;A2:A7=A13)

das kommt mir allerdings falsch vor. Wie mache ich es richtig?
Antwortento top
#6
Dieser Teil reicht:
Code:
=MITTELWERTWENNS(H2:H7;A2:A7;A13)
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
[-] Folgende(r) 1 Benutzer sagt Danke an shift-del für diesen Beitrag:
  • tps9
Antwortento top
#7
Vielen Dank!

Hat super funktioniert!
Antwortento top
#8
Guten Tag zusammen,

ist das wirklich der Wert, den du suchst, da es lediglich das arithmetische Mittel ist. 

UND nicht der gewichtete Mittelwert; eine Lösung habe ich dafür allerdings auch nicht parat.

MfG

Ich habe mal Nachforschungen betrieben und ich bin zu dieser Formel gekommen. Leider erhalte ich dafür eine Fehlermeldung (ich denke, dass der Summenbereich <> dem Kriterienbereich ist).

Summewenns(summenprodukt(H2:H7;I2:I7);A2:A7;A13)

hat jemand eine andere Lösung?
Antwortento top
#9
Hallo,
Vorschlag für gewichtetetn Mittelwert "Schwarz":

=SUMMEWENN(A2:A7;A13;G2:G7)/SUMMENPRODUKT((D2:D7)*(E2:E7)*(A2:A7=A13))
Cadmus
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste