Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Gewichtete Laufzeit von Verträgen ohne Hilfsspalte
#1
Hallo zusammen,

ich bin bei einer "Aufgabenstellung" in Excel leider an meine Grenzen gestoßen.. Und zwar habe ich eine Liste von Verträgen mit Betrag. Jetzt möchte ich auf einen Stichtag bspw. den 01.08.2020 die gewichtete Vertragslaufzeit berechen. Bis jetzt habe ich das immer über eine Hilfsspalte und die Funktion brtljahre gemacht. Leider muss/möchte ich es dieses mal ohne Hilfssplate berechen.

Beispiel:
Vertragsnummer    Betrag       Laufzeit
Vertrag 1               200€        31.12.2020
Vertrag 2               100€        31.12.2021
Vertrag 3               100€        31.12.2022

Ergebnis bei diesem Beispiel wäre 1,16666666666667

Über Hilfe wäre ich sehr dankbar.

Beste Grüße
Antwortento top
#2
Hi,


Zitat:Bis jetzt habe ich das immer über eine Hilfsspalte und die Funktion brtljahre gemacht. Leider muss/möchte ich es dieses mal ohne Hilfssplate berechen.
wenn du die Helfer an (d)einer (Beispiel)Datei teilhaben lässt, beschleunigt das einen Lösungsvorschlag sicherlich. Wink So geht's Hochladen: https://www.clever-excel-forum.de/Thread...ng-stellen
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#3
=SUMMENPRODUKT(B2:B4*(C2:C4-DATUM(2020;8;1)))/SUMME(B2:B4)/365,25

In B stehen die Euros und in C die Enddaten. Bei mir kommt als Ergebnis 1,16563997262149 heraus.

Bei Verwendung von BRTEILJAHRE mit Ergebnis 1,1666666667 musst Du die "Krücke" MTRANS anwenden und als Matrixformel eingeben (mit STRG + SHIFT + ENTER eingeben, nicht nur mit ENTER):
=SUMMENPRODUKT(B2:B4*MTRANS(BRTEILJAHRE(DATUM(2020;8;1);MTRANS(C2:C4))))/SUMME(B2:B4)
Antwortento top
#4
Vielen Dank für eure Antworten. Die Formeln haben einwandfrei funktioniert  Thumps_up
Danke auch für den Tipp fürs hochladen.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste