Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Funktion schützen
#1
Hallo ich habe eine Summewenns funtkion:
=SUMMEWENNS(Orginal!$J4:J;Orginal!$C$4:$C$3000;C5;Orginal!$F$4:$F$3000;$B$4)
hier kommen die Daten aus dem Blatt "Orginal" 
jetzt muss ich das Blatt Orginal  wöchenlichen  ändern - möchte allso das Blatt Orginal lösen ----- jetzt verändert sich die Funktion 
weil der Bezug fehlt:
=SUMMEWENNS(#BEZUG!$J$4:$J$3000;#BEZUG!$C$4:$C$3000;C5;#BEZUG!$F$4:$F$3000;$B$4)
Wie kann ich erreichen das der Bezug immer stehen bleibt auch wenn ich das Blatt lösche.
Antwortento top
#2
Mehrere Optionen:

-Kopieren doch einfach neue Daten in das Blatt und überschreibe die alten Daten einfach.

- Nutze für den Datenimport PowerQuery.

- INDIREKT() um die Bereiche in der Funktion nutzen


BG ruppy
Antwortento top
#3
Danke für die Antwort die dann wohl - bedeutet so wie ich mir das vorstelle geht das nicht.

Den Schritt mit dem Kopieren wollte ich mir sparen altes Blatt löschen neues Umbenennen...

 Datenimport PowerQuery durch PowerQuery schau ich mir mal an...

Wie gesagt Danke  
Antwortento top
#4
Wenn du das Blatt danach wieder "Original" nennst und die Bezüge identisch sind, dürfte es mit INDIREKT() funktionieren.

SUMMEWENNS(INDIREKT("Dein Bezug");...)

und das für alle Bezüge die auf das Blatt "Original" verweisen.

BG ruppy
Antwortento top
#5
Hallöchen,

Du kannst #BEZUG einfach mit Suchen & Ersetzen behandeln Smile Dann brauchst Du nicht kopieren. Was Du halt als einfacher empfindest.
Zu INDIREKT noch ein Hinweis. Das kann die Performance bei größeren Datenmengen verlangsamen.
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste