Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Funktion mit mehreren Bedingungen
#1
Hallo zusammen,

ich bin neu hier und habe leider kein passendes bereits existierendes Thema gefunden. 
Deswegen hier mein Problem.

Ich habe folgendes Tabellenformat.

A1 = hier ist ein drop down mit 103 Möglichkeiten hinterlegt
B1 = hier ist ein drop down 84 Möglichkeiten hinterlegt
C1 = hier ist ein drop down mit 4 Mglk. hinterlegt
D1 = dropwdown mit 5 Mglk.

Zelle A1-D1 müssen alle befüllt werden. Es ergibt sich für jede Auswahl ein anderer Wert (insgesamt 558 Varianten), der dann aus einer Matrix in Zelle E1 dargestellt werden soll.

Ich habe das Ganze bisher mit folgender Formel dargestellt:

=WENN(UND(C9="ALL-DE";D9="MNULN";E9=40100;F9="no");"DE1";"no agreed rate")

Das funktioniert auch soweit & ich bekomme auch das Ergebnis, das ich möchte.

Jetzt meine Fragen: Gibt es eine einfachere Möglichkeit, diese Formel so zu erweitern, dass in Zelle E1 bei jeder der 558 Kombinationsmöglichkeiten der entsprechende Wert wiedergegeben wird, ohne dass ich alle 558 Mglk. abtippen muss?  Huh

Vielen Dank vorab für Euren Rat &
Viele Grüße
Antwortento top
#2
Hallo,

mit einer Beispieltabelle wird es sicherlich klarer, was du meinst. Lies mal bitte hier: https://www.clever-excel-forum.de/Thread...ng-stellen
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.zitate.net
Antwortento top
#3
Hallo Günther,

anbei meine Beispieltabelle.

Vielen Dank 


.xlsx   Mappe2.xlsx (Größe: 33,94 KB / Downloads: 15)
Antwortento top
#4
Hola,

Code:
=VERWEIS(2;1/(Tabelle3!A2:A559&Tabelle3!B2:B559&Tabelle3!C2:C559&Tabelle3!D2:D559=A2&B2&C2&D2);Tabelle3!E2:E559)

Gruß,
steve1da
Antwortento top
#5
Hi Steve,

bekomme als Ergebnis leider #NV...
Antwortento top
#6
Hola,

sorry:
Code:
=WENNFEHLER(VERWEIS(2;1/(Tabelle3!A2:A559&Tabelle3!B2:B559&Tabelle3!C2:C559&Tabelle3!D2:D559=A2&B2&C2&D2);Tabelle3!E2:E559);"no agreed rate")

Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • SteBen
Antwortento top
#7
Funktioniert, super - Vielen Dank!!  28
Antwortento top
#8
Hi Steve,

bräuchte noch mal Deine HilfeSmile

Ich musste nun D5 löschen.
Leider zieht sich Excel nun die Werte nicht mehr in E1.

Wie muss die Formel verändert werden, damit es wieder passt?

Danke noch mal
Antwortento top
#9
Hola,

D5 in welchem Blatt?
In E1 steht überhaupt keine Formel.

Ergo: keine Ahnung was du meinst.

Gruß,
steve1da
Antwortento top
#10
Hi,

anbei noch mal meine Datei.

In Zelle E2 soll sich das routing anhand der Kriterien aus A2, B2 & C2 gezogen werden. Daten sind in Tabelle 3 gelistet.

Vielen Dank

.xlsx   Mappe2.xlsx (Größe: 42,45 KB / Downloads: 2)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste