Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Frage mit Antworten
#1
Hallo zusammen!
Ich benötige mal eure Hilfe...

Ich möchte eine Checkliste erstellen, die im Endeffekt mit einer Frage beginnt (die man per dropdown mit "ja" oder "nein" beantworten kann.
Je nach dem was ich geantwortet habe, sollte jetzt entweder ein kleiner Infotext erscheinen oder eine 2te Frage kommmen.... Ein Beispiel:

1. Frage: Ist die Erde Rund?   [ja /nein]
    bei ja: "Richtig!"
 
Antworte ich mit "nein" sollte die nächste Frage kommen (die 2te Frage sollte dann in der Zeile darunter erscheinen):

2.Frage: Glaubst du die Erde ist Eckig? [ja/nein]
   bei ja: "du liegst falsch"

usw usw.....

Ich hab es schon soweit hin bekommen (Wenn  Funktion) dass bei der Antwort "Ja" der Text erscheint.
=WENN(A1="Ja"Richtig";Glaubst du die Erde ist Eckig?")

Allerdings weiß ich nicht, wie ich bei "nein" eine weitere Frage einleite, also ich wieder ein Dropdown bekomme....

Vielleicht gibt es ja auch einen besseren Lösungsansatz!

Ich hoffe Ihr könnt mir weiterhelfen!
Antwortento top
#2
Hallöchen,

hier mal ein Ansatz. In Spalte A kommen per Formel so lange neue Fragen, wie zuvor nein als Bewertung kam. Die Bewertung wird hier auch per Formel berechnet. Nach dem ersten ja wäre also Schluss.
In E1:F3 stehen hier die Fragen und Antworten. #NV bekommt man mit WENNFEHLER weg. Dann müsste man auch noch den "Anfang" in den Formeln berücksichtigen, wenn noch keine Antwort gegeben wurde Smile

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDEF
1FrageAntwortBewertungwerich
2werduneinwashose
3washosejawarumdeshalb
4#NV

ZelleFormel
A2=E1
C2=WENN(SVERWEIS(A2;$E$1:$F$3;2;FALSCH)=B2;"ja";"nein")
A3=WENN(C2="nein";INDEX($E$2:$E$3;ZÄHLENWENN($C$1:C2;"nein");1);"")
C3=WENN(SVERWEIS(A3;$E$1:$F$3;2;FALSCH)=B3;"ja";"nein")
A4=WENN(C3="nein";INDEX($E$2:$E$3;ZÄHLENWENN($C$1:C3;"nein");1);"")
C4=WENN(SVERWEIS(A4;$E$1:$F$3;2;FALSCH)=B4;"ja";"nein")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste