Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Formel per VBA einfügen, Syntaxfehler
#1
Hallo Forum,

ich versuche mit folgendem Code per VBA eine Formel in Tabelle "Tabelle1" Zelle "A1" einzufügen,
leider bekomme ich hier die Meldung:

Fehler beim Kompilieren:

Syntaxfehler


und in der VBA Formel wird mir nach "INDIREKT" das "A" markiert.


Code:
Sub Test()
Dim Zelle As Range
Dim Nr As Long
For Each Zelle In Worksheets("Tabelle1").Range("A1")
Nr = Zelle.Row
Zelle.FormulaLocal = "=SUMME(N(HÄUFIGKEIT(ZEILE(1:100);TEILERGEBNIS(3;INDIREKT("A"&ZEILE(4:9000)))*VERGLEICH(A4:A9000&"";A4:A9000&"";))>0))-1"
Next Zelle
End Sub


Besten Dank im Voraus
omron2003
Antwortento top
#2
Hallo,

verdoppele alle Anführungszeichen außer dem ersten und letzten.

Gruß Uwe
Antwortento top
#3
Hallo Omron,

Formeln mit VBA einfügen erscheint mir schon grundsätzlich etwas seltsam, in Anbetracht der Tatsache, das VBA selbst vorzüglich rechnen kann. Aber eine einzelne Formel per VBA? Da kann ich nur fragen: geht es noch? Das ist mehr als mit Kanonen auf Spatzen geschossen.
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
Antwortento top
#4
Hallo Kuwer,

Besten Dank für die schnelle Hilfe, mit den zusätzlichen Ausführungszeichen funktioniert es jetzt.

@ Klaus Dieter
ja es gibt bestimmt bessere Lösungen, aber die  Tabelle wo ich diese Formel benötige
wird über SAP Script gelösch und in einem Zyklus neu gefüllt. Hierbei wir jedes mal auch die
Formel gelöscht....

Gruß
omro2003
Antwortento top
#5
Code:
For Each Zelle In Worksheets("Tabelle1").Range("A1")

Wie viele Zellen hat dein Rechner in range "A1" ????
Zum übersetzen von Excel Formeln:

http://dolf.trieschnigg.nl/excel/index.p...gids=en+de
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste