Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Färben von Zelle wenn Zellnachbarn Text haben
#1
Guten Tag zusammen,

long time no see. Ich hoffe es geht allen gesundheitlich gut und keiner ist zu sehr von Covid getroffen!


Meine Frage ist wie schaffe ich es über VBA (oder anders) es so zu definieren, dass sich eine Zelle in einer bestimmten Farbe färbt wenn in den beiden Zellen rechts und links daneben ein Wert steht (einfach nicht leer). Es kann auch sein das es mal mehr Spalten zwischen den Zellen mit Inhalt gibt, dann soll "Verbindungsstück" auch länger sein.

ich hab eine datei angehangen die hoffentlich aufschlussreicher ist.



Vielen dank


Angehängte Dateien
.xlsx   CE Forum - automatisch Zellenfärben.xlsx (Größe: 12,65 KB / Downloads: 5)
Antwortento top
#2
Hola,

als Formel in der bedingten Formatierung:

Code:
=(SPALTE()>=VERGLEICH("x";$A2:$J2;0))*(SPALTE()<=VERGLEICH("";$A2:$J2;-1))

Gruß,
steve1da
Antwortento top
#3
danke dir sieht schon mal sehr gut aus nur noch 2 Fragen.

1. Er färbt bei mir immer die Zellen oberhalb der Zeile in welche die Werte sind. 
2. Kann man das so umschreiben das er nicht nach "x" schaut sondern ob Inhalt in der Zelle ist? 


danke dir schon mal steve
Antwortento top
#4
Hola,

1) dann hast du nicht A2 bis J7 markiert sondern A1 bis Irgendwas
2) mach aus dem X ein Fragezeichen

Gruß,
steve1da
Antwortento top
#5
Klappt perfekt danke dir
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste