Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Excelformel -> Macformel
#1
Hallo,

leider habe ich keine Ahnung von Mac und dessen Syntax in den Formeln.

Eine bei mir tatellos laufende Excel-Arbeitsmappe soll auch unter Mac laufen, leider tut sie das nicht!
Bei einer Excel-Bezugsformel auf Werte in einem anderen Tabellenblatt erzeugt Mac nur #BEZUG! - hier die Formel:
=WENN(Bestellaufnahme!$D7="X";Bestellaufnahme!$E7;)

Da ich nicht die Mac-Datei zur Verfügung habe, vermute ich, dass Mac auch mit den Excel-Matrix-Formeln nicht zurecht kommt - da habe ich folgend drin:
=WENN($A7="";"";SVERWEIS($A7;Adressen!$A$4:$E$300;2;0))
Diese erzeugt in Excel ein #NV, da Mac das WENNFEHLER nicht beherrscht, ist aber nicht relevant.

Kann mir jemand bei der richtigen Übersetzung in die Macverständliche Syntax helfen?

Gruß Günter
aus der Helden-, Messe-, Musik-, Buch-, Universitäts- und Autostadt Leipzig
Antwortento top
#2
Hola,

auf dem Mac funktionieren excel Formeln genau so wie unter Windows!
Gruß,
steve1da
Antwortento top
#3
Hallo steve1da,

danke für die Info - hat mich auf die Spur meines"dummen" Fehlers gebracht!
Hatte das Tabellenblatt, auf das Bezug genommen wird, umbenannt und die Auswirkungen auf die Formeln nicht bedankt.

Gruß Günter
aus der Helden-, Messe-, Musik-, Buch-, Universitäts- und Autostadt Leipzig
Antwortento top
#4
Hallo Günter,

das ist so nicht nachvollziehbar, denn Excel ändert bei Umbenennung eines Tabellenblatts die Bezüge in den Formeln automatisch mit.
Schöne Grüße
Berni
Antwortento top
#5
Hallo Mister Bums,

leider war es aber so! Es könnte möglicherweise auch damit zusammenhängen, dass es eine xlsm-Arbeitsmappe war, die zurückkonvertiert in eine xls-Arbeitsmappe von Excel 2013 auf Excel 2003 war. Excel 2003 meckerte beim Speichern, dass es einige Funktionen nicht berechnen kann.
Jetzt ist jedenfalls alles in Ordnung und die Datei läuft unter Mac.

Verstehen tue ich allerdings nicht, warum jemand Windows-Rechner mit Office 2013 und Mac-Rechner hat und auf beiden die gleichen Dateien laufen haben will. Ist aber nicht mein Problem ...

Gruß Günter
aus der Helden-, Messe-, Musik-, Buch-, Universitäts- und Autostadt Leipzig
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste