Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

[Excel] Probleme bei der Nutzung von Vergleich bei 3 Vergleichsfelden
#1
Hallo,

ich habe irgendwie Knoten im Hirn und komme gerade nciht weiter.
Ich habe einen Matrix, in der ich mittels eintrag von "X" eine Kombination dieser beide Wert ausschließe und es einen Hinwiestext gibt. Das klappt auch, solange ich nur 2 Zellen damit überprüfe.
Möchte ich nun weitere Zellen in die Prüfung aufnehmen, bekomme ich dies nicht hin.

Dies funktioniert auch:
Code:
=WENNFEHLER(WENN(INDEX('2-Gruppenmatrix'!$B$2:$W$23;ODER(VERGLEICH(E20;'2-Gruppenmatrix'!$A$2:$A$23;0)="x";VERGLEICH(I20;'2-Gruppenmatrix'!$B$1:$W$1;0)="X";
VERGLEICH(N20;'2-Gruppenmatrix'!$B$1:$W$1;0)="x";VERGLEICH(R20;'2-Gruppenmatrix'!$B$1:$W$1;0)="x"));"prüfen";"");"")

Hiermit werde die Zellen E20 und I20 gegenübergestellt. Dies möchte ich nu naber auch für die Zellen N20 und R20 machen. Sobald also bei irgendiener Kombination ein"X" erscheint, soll der Text prüfen in die Zelle geschrieben werden.
Code:
=WENNFEHLER(WENN(INDEX('2-Gruppenmatrix'!$B$2:$W$23;ODER(VERGLEICH(E20;'2-Gruppenmatrix'!$A$2:$A$23;0)="x";VERGLEICH(I20;'2-Gruppenmatrix'!$B$1:$W$1;0)="X";
VERGLEICH(N20;'2-Gruppenmatrix'!$B$1:$W$1;0)="x";VERGLEICH(R20;'2-Gruppenmatrix'!$B$1:$W$1;0)="x"));"prüfen";"");"")
 Mit der Variante funktioniert noc nicht mal mehr die erste Prüfung zwischen E20 und I20.

Ich habe die Exceltabelle mal in Auszügen beigefügt.
Das ganz soll ohne Makros/VBA laufen.


Angehängte Dateien
.xlsx   200718_Forumsversion.xlsx (Größe: 44,75 KB / Downloads: 7)
Antwortento top
#2
(18.07.2020, 15:36)Sir_Dirk schrieb: Dies funktioniert auch:
Das glaube ich nicht, Tim.

Ich würde die ganze Struktur überarbeiten.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#3
also bei mir klappt es, wenn ich nur die linke oder rechte Platzhälfte nutze.

Was meims du mit Übeprüfung der Struktur?
Ich bin froh es so hinzubekommen.

Veilen Dank schon einmal vorab.
Antwortento top
#4
Überarbeitung, nicht Überprüfung.

Mit der richtigen Struktur schreiben sich die Formeln quasi von alleine (ZÄHLENWENNS(), SUMMEWENNS()).

Die Matrix in Blatt 2-Gruppenmatrix würde ich in diese Form umschreiben:
Trainingsgruppe 1 - Trainingsgruppe 2
In der Liste stehen dann natürlich nur entweder die erlaubten oder nur die nicht erlaubten Kombinationen.
Ich würde mich vermutlich für die Variante entscheiden die weniger Einträge benötigt.

Auch der Rest lässt sich bestimmt noch verbessern.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste