Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Excel KKleinste bzw. kGrößte mit Bedingung
#1
Hallo zusammen,

ich habe ein excel problem, was ein Wunder :D

ich hab Kunden sagen wir x,y je Umsatz.
jetzt möchte ich das eine liste erstellt wird mit den Kunden ab 50 EUR Umsatz. 

ich habe es mit kkleinste bzw. Kgrößte versucht , das problem ist das die Formel mir auf den ersten platz dann die 50 ausgeben soll und auf den 2 platz zum beispiel die 51 und nicht immer direkt den kleinsten oder größte wert.

Rang  Kunde  Umsatz
1         a         50
2         b         51
3         g         usw
4         f
5         g


ich hoffe ihr könnt mir helfen.
Viele Grüße
Crank15
Antwortento top
#2
Hallo,

falls ich dich richtig verstanden habe:
Arbeitsblatt mit dem Namen 'Tabelle2'
AB
12750
24551
35052
45153
51266
615
753
866
916
1052

ZelleFormel
B1=WENNFEHLER(KKLEINSTE(WENN($A$1:$A$10>=50;$A$1:$A$10);ZEILE(A1));"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#3
wooow das ist Super!!!!!!!!!!!!!!!!!!!

Vielen Dank!!!

ich hab noch eine andere Frage :D
ich möchte jetzt auch den jeweiligen namen des Kunden in der neben Spalte aufgelistet bekommen. Also einmal 50Euro und dann dazu noch den jeweiligen Kundennamen. 

=INDEX(Sheet1!$U:$U;VERGLEICH(KGRÖSSTE(Sheet1!$L:$L;ZEILE(A1));Sheet1!L:L;0);SPALTE(A1))

mit der Formel gibt er mir schon mal den größten Wert aus aus der Liste aus. jedoch hab ich es nicht Geschaft die Formel da einzubauen, damit er mir auch noch in der neben Spalte den Namen ausgibt.
Antwortento top
#4
Hallo,



falls mit Version 2006 im Profil Office 365 gemeint ist:


Tabelle1
ABCDE
250Name A50Name A
345Name B50Name c
450Name c51Name d
551Name d52Name K
612Name e53Name g
715Name F66Name h
853Name g
966Name h
1016Name I
1152Name K

verwendete Formeln
Zelle Formel Bereich N/A
D2=SORTIEREN(FILTER(A2:B11;A2:A11>=50);1;1)
http://excel-inn.de/dateien/vba_beispiel..._addin.zip
http://Hajo-Excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 25.21 einschl. 64 Bit

Cadmus
Antwortento top
#5
Hi,

für die Nicht-365-er:
Arbeitsblatt mit dem Namen 'Tabelle1'
ABCD
127Berta50Agnes
245Robert51Arthur
350Agnes52Helene
451Arthur53Berta
512Arthur66Helene
615Robert
753Berta
866Helene
916Johann
1052Helene

ZelleFormel
C1=WENNFEHLER(KKLEINSTE(WENN($A$1:$A$10>=50;$A$1:$A$10);ZEILE(A1));"")
D1=WENNFEHLER(INDEX(B:B;VERGLEICH(C1;$A$1:$A$10;0));"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#6
Index vergleich funktioniert leider nicht, da ich mehrere Doppelte Werte habe mit verschiedenen Name :/

gibt es da noch eine andere Formel?
Antwortento top
#7
Prima, dass wir das jetzt schon erfahren. Welche Excel-Version besitzt du nun? 2006 ist mir nicht bekannt.

Hier mal ein Vorschlag mit 2 Hilfsspalten (farbig hinterlegt), die du einfach ausblenden kannst:
Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDEF
127Berta350Agnes
245Robert450Arthur
350Agnes3753Berta
450Arthur4866Helene
512Arthur1066Petra
615Robert####
753Berta7####
866Helene8####
916Johann####
1066Petra10####

ZelleFormel
C1=WENN(A1>=50;ZEILE();"")
D1=KKLEINSTE($C$1:$C$10;ZEILE(A1))
F1=WENNFEHLER(INDEX(B:B;D1);"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#8
Danke für eure Hilfe!

ich habe Version 2005.
Antwortento top
#9
Hi,

2005? Wieso steht "2006" im Profil? Dies war aber nicht gemeint. Unter welcher Bezeichnung wurde diese gekauft?

Office 2007, 2013, 2016, 2019 oder Office 365 als Abo?
Cadmus
Antwortento top
#10
Hi Crank,

weil ich vorhin weg musste, hatte ich völlig übersehen, dass eine Hilfsspalte ausreicht (Spalte C). Du musst die Formel nur abändern:
Code:
=WENNFEHLER(INDEX(B:B;KKLEINSTE($C$1:$C$10;ZEILE(A1)));"")
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste