Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Excel 2007 wenn, dann
#1
Hallo Alle,
Ich brauche eine einfache Formel für:
Wenn z.B. a1 gleich 1 bis 100 dann den Wert von b1 bis b100
d.h. wenn ich in Zelle a1 29 eingebe, dann soll in diese Zelle den wert von b29 erscheinen.

bis jetzt haben ich eingegeben:
=WENN(Auslösung!B2=1;Liste!B2;WENN(Auslösung!B2=2;Liste!B3;WENN(Auslösung!B2=3;Liste!B4;WENN(Auslösung!B2=4;Liste!B5;WENN(Auslösung!B2=5;Liste!B6;WENN(Auslösung!B2=4;Liste!B5;WENN(Auslösung!B2=5;Liste!B6;WENN(Auslösung!B2=6;Liste!B7;WENN(Auslösung!B2=7;Liste!B8;WENN(Auslösung!B2=8;Liste!B9;WENN(Auslösung!B2=9;Liste!B10;WENN(Auslösung!B2=10;Liste!B11;WENN(Auslösung!B2=11;Liste!B12;WENN(Auslösung!B2=12;Liste!B13;WENN(Auslösung!B2=13;Liste!B14;WENN(Auslösung!B2=14;Liste!B15;WENN(Auslösung!B2=15;Liste!B16;WENN(Auslösung!B2=16;Liste!B17;WENN(Auslösung!B2=17;Liste!B18;WENN(Auslösung!B2=18;Liste!B19;WENN(Auslösung!B2=19;Liste!B20;WENN(Auslösung!B2=20;Liste!B21;WENN(Auslösung!B2=21;Liste!B22;WENN(Auslösung!B2=22;Liste!B23;WENN(Auslösung!B2=13;Liste!B24;WENN(Auslösung!B2=24;Liste!B25;WENN(Auslösung!B2=25;Liste!B26;WENN(Auslösung!B2=26;Liste!B27;WENN(Auslösung!B2=27;Liste!B28;WENN(Auslösung!B2=28;Liste!B29;WENN(Auslösung!B2=29;Liste!B30;WENN(Auslösung!B2=30;Liste!B31;WENN(Auslösung!B2=31;Liste!B32;WENN(Auslösung!B2=32;Liste!B33;WENN(Auslösung!B2=33;Liste!B34;WENN(Auslösung!B2=34;Liste!B35;WENN(Auslösung!B2=35;Liste!B36;WENN(Auslösung!B2=36;Liste!B37;WENN(Auslösung!B2=37;Liste!B38;WENN(Auslösung!B2=38;Liste!B39;WENN(Auslösung!B2=39;Liste!B40;WENN(Auslösung!B2=40;Liste!B41;
))))))))))))))))))))))))))))))))))))))))))

Es gibt bestimmt eine einfachere Lösung dafür und so kann das nicht bleiben, vor allem, wenn ich diese auf 100 erweitern muss.

Bitte um F1 (Hilfe), Danke
Antwortento top
#2
Hola,

Code:
=INDEX(Liste!B2:B101;B2)


Gruß,
steve1da
Antwortento top
#3
(16.07.2020, 07:16)Ralf12 schrieb: d.h. wenn ich in Zelle a1 29 eingebe, dann soll in diese Zelle den wert von b29 erscheinen.
[...]
WENN(Auslösung!B2=29;Liste!B30;...)
Text sagt so, Formel sagt so.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#4
Moin!
Beliebige "Länge" dann mittels
=INDEX!Liste!B:B;B2+1)

Gruß Ralf
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antwortento top
#5
Hallo Ralf,

was die bisherigen Antworter Dir sagen wollten (oder auch nicht), ist, dass die Funktion INDEX() die geeignetere ist.
In Deinem Fall dann richtig: =INDEX(Liste!B:B;Auslösung!B2+1)

Gruß Uwe
Antwortento top
#6
Vielen herzlichen Dank,
Ich probiere heute Nachmittag aus und sage dann Bescheid.
LG
Ralf12
Antwortento top
#7
Mit dem Index-befehl kam ich leider so nicht  weiter.
Ich beschreibe nochmal mein Problem.
In der Spalte A habe ich durchlaufende nr. (1-40 ,soll aber auf 50 erweitert werden)
In der Spalte B sind Namen von 40 Teilnehmer
In Zell c1 gebe ich eine Zahl ein (z.B. 5)
In Zelle D1 soll der Name von Teilnehmer nr. 5 aus der Spalte  B erscheinen.
also wie folgt:
Spalte A     Spalte B      Spalte C      Spalte D
1                 Ralf                5            Gabi
2                 Peter             3            Jürgen
3                 Jürgen          6            Ulrike
4                 Heinz            und so weiter
5                 Gabi
6                 Ulrike
.
.
.
usw

LG
Antwortento top
#8
Hola,

Code:
=INDEX(B:B;C1)

Code:
=SVERWEIS(C1;A:B;2;0)


Gruß,
steve1da
Antwortento top
#9
Liebe (r) steve1da 
Es funktioniert,   97  vielen vielen Dank. Du hast mir sehr geholfen. Aber eine Frage noch: Wenn ich in Spalte C nichts eingebe, soll auch in der Spalte D nichts erscheinen.
Im Moment erscheint beim Index-befehl der Inhalt von Spalte B und beim SVERWEIS-Befhl   [ Bild bitte als Datei hochladen! ]. hast Du auch eine Lösung dafür?

Viele schöne Grüße
Ralf

beim SVERWEIS-Befhl  #NV
Antwortento top
#10
Hola,

pack beim Sverweis einfach WENNFEHLER() um die Formel.

Gruß,
steve1da
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste