Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Duplikate in einer Spalte erkennen und nur die größte Zahl einer anderen Spalte zähle
#1
Guten Morgen Excel-perten!

Ich tüfftle schon seit einiger Zeit an einer Formel, finde jedoch keine Lösung dafür.
Daher wende ich mich nun als letzten Ausweg an euch und hoffe dass mir jemand einen Tipp geben kann.  17
Zur Ausgangslage: Ich habe eine doch sehr umfangreiche Tabelle mit Kundendaten. Darin sind viele Kunden doppelt angeführt.
So befindet sich in jeder Zeile Kundennumer, Name, Anschrift, ... und unter anderem eine Zahl die angibt wieviele Personen mit diesem Kunden mitbetreut werden.

z.B.
123456      Max      Mustermann      Mustergasse 1      (4)
123456      Max      Mustermann      Mustergasse 1      (2)
987654      Paul      Platzhalter          Halterplatz 2         (1)

Und jetzt das Problem:
Ich hätte gerne, dass von diesen Zahlen die SUmme gebildet wird, wobei bei Doppelnennungen nur die höchste Zahl gezählt werden soll.
In diesem Beispiel wären das 5.

Vielen Dank für eure Unterstützung!
Marcus
Antwortento top
#2
Hallo,

um diese Zeit gibt es nur einen Ansatz:

- ein neues Blatt anlegen
- mit dem Spezialfilter die Spalte A (ID's) ohne Duplikate in das neue Sheet kopieren
- für Formelspezialiste: mit "=aggregate()" das Max der Spalte 5 pro ID ermitteln
- VBA Range.Find

mfg
Antwortento top
#3
Hallo Fennek!

Danke für Deinen Vorschlag. Leider sind Filter- oder Pivot-Lösung nur bedingt möglich.
Die Tabelle muss teilweise händisch befüllt werden und dies geschieht durch reine Anwender. Da sollte alles so einfach wie möglich sein. Wink  

Liebe Grüße
Marcus
Antwortento top
#4
Wenn Du Dir XL365 kaufst oder XL-Online kostenlos benutzt werden kann:

A1:C6:
Name VN Wert
...

K1: 
=SORTIERENNACH(
A2:INDEX(C:C;ANZAHL2(A:A));
A2:INDEX(A:A;ANZAHL2(A:A));1;
B2:INDEX(B:B;ANZAHL2(A:A));1;
C2:INDEX(C:C;ANZAHL2(A:A));1)


U1:
=SUMME(INDEX(FILTER(K1#;
INDEX(K1#;;1)&
INDEX(K1#;;2)<>
INDEX(BEREICH.VERSCHIEBEN(K1#;1;);;1)&
INDEX(BEREICH.VERSCHIEBEN(K1#;1;);;2));;3))


Falls Dich die Hilfszellen K1 stören, verschiebe sie einfach auf ein neues Blatt, welches Du ausblenden kannst.

Ich habe die Daten auf 3 Spalten verkleinert, so dass Du noch siehst, wie es geht.
Antwortento top
#5
Hallo LCohen!

Dankeschön für den Lösungsansatz! Leider kann ich die Excelversion in der Firma nicht ändern.
Ich habe mir schon eine Hilfsspalte gemacht, welche den beginn eines Blocks mit dem selben Namen mit einer "1" markiert.

Also..
Mustermann     1
Mustermann     0
Mustermann     0
Beispiel              1
Beispiel              0
Platzhalter         1
Die Formel ist (Von-Datum und Bis-Datum sind hierfür unerheblich):

=([Familienname]<>INDEX([Familienname];ZEILE()-ZEILE(Tabelle1[#Kopfzeilen])+([Familienname]=INDEX([Familienname];ZEILE()-ZEILE(Tabelle1[#Kopfzeilen])-1))*(INDEX([Bis-Datum];ZEILE()-ZEILE(Tabelle1[#Kopfzeilen])-1)+1<>[@Von-Datum])*([@Bis-Datum]>INDEX([Bis-Datum];ZEILE()-ZEILE(Tabelle1[#Kopfzeilen])-1)*(ZEILE()>ZEILE(Tabelle1[#Kopfzeilen])+1)+1)
Jetzt habe ich aber irgendwie eine Hirnblockade   92 Ich komme einfach nicht darauf wie ich nun die größten Wert in der Nebenspalte summiere.

Liebe Grüße
Marcus
Antwortento top
#6
Hallo Marcus,

angenommen Zeile1 enthält Kundennumer, Vorname, Name, Vorname, Anzahl Personen (Zahl)

dann probier mal folgende Formel:

=SUMMENPRODUKT(MAXWENNS(E2:E99;A2:A99;A2:A99)*ISTZAHL(1/(VERGLEICH(A2:A99;A:A;0)=ZEILE(A2:A99))))

Bereiche müssen angepasst werden!

Viele Grüße
Georg
Antwortento top
#7
Hallo Georg!

Herzlichen Dank für die Formel! Leider hab ich die Professional Version vom Office 2016 ohne die 365 Lizenz.
Und da gibt es die MAXWENNS-Formel noch nicht. 20

Aber die Richtung ist super! 28

Liebe Grüße
Marcus
Antwortento top
#8
Hallo,

mit einer Hilfsspalte:


.xlsx   Summe.xlsx (Größe: 9,36 KB / Downloads: 9)
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#9
Guten Morgen Edgar!

Wow, herzlichen Dank! 

Funktioniert super, danke! 35

Nur werden bei zwei oder mehreren gleichen Zahlen immer alle gezählt. Hast Du dafür vielleicht auch einen Lösungsansatz parat?
Wäre Dir dafür sehr dankbar!

Liebe Grüße Marcus
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste