Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Dropdown Liste an bedingung geknüfpt
#1
Hallo Leute,

folgendes Problem:

Eine Dropdown Liste soll in Excel nur bestimmte Werte anzeigen die größer sind als ein Wert in einer anderen Zelle.

ZB: in Zelle A1 steht 10

In einem anderen Blatt (hier sind die Werte hinterlegt) steht das Tobi 5, Andreas 4, Max 18 und Lisa 22 hat.
wenn in Zelle A1 10 steht, soll in der Dropdown Liste (in Zelle A2) nur Max und Lisa auswählbar sein.

Wie stelle ich das an?? Wahrscheinlich muss eine Wenn und Sverweis Fkt mit rein aber wie ist die Frage.

danke für eure Hilfe.

LG Lukas
Antwortento top
#2
Hallöchen,

Du müsstest Dir eine gekürzte Liste als Quelle des Dropdown erstellen, hier mal der Ansatz daz:

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDE
11Tom4Lisa
25LisaMax
310Max

ZelleFormel
E1{=WENNFEHLER(INDEX(B$1:B$99;KKLEINSTE(WENN((A$1:A$99>$D$1);ZEILE($1:$99));ZEILE()));"")}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#3
Danke für die Antwort.
Funktioniert leider nicht so wie ich mir das wünsche.

Nochmals genauer das Problem beschrieben.

In Blatt 1 in Zelle A1 soll eine Dropdown Liste erstellt werden.
In Blatt 1 in Zelle A2 steht ein Wert: Zb: 5

In Blatt 2 in Spalte A sind Namen
In Blatt 2 in Splate B-F sind verschiedene Werte
In Blatt 2 in Spalte G sind die gesuchten Werte
in Blatt 2 in Spalte H-I sind verschiedene Werte

Wenn der Wert in A2 (Blatt 1) größer ist als bestimmte Werte in Spalte G (Blatt 2) sollen in der Zelle A1 (Blatt 1) nur Werte von der Spalte G (Blatt 2) vorkommen, die größer sind als A2 (Blatt 1).

Kompliziert erklärt, bin mir sicher es gibt eine recht einfache Lösung nur bin ich da leider nicht so erfahren.

Danke nochmals im Vorraus.

LG
Antwortento top
#4
Hallo Nico,

um dir helfen zu können, solltest du eine Beispieldatei (keine Bildchen!!) zur Verfügung stellen. https://www.clever-excel-forum.de/Thread...ng-stellen
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#5
Wäre mein nächster Schritt gewesen.Smile
Ist zwar nicht das Original File, aber das schaffe ich dann schon denke ich..

Hier ein Bild:

in diesem Fall soll in der Liste (B2) zb nur Anton und Gustav zum auswählen sein.

[ Bild bitte als Datei hochladen! ]

Hier das Bild. Ist aber 1 zu 1 das gleich wie die Excel Datei.


Angehängte Dateien Thumbnail(s)
   

.xlsx   Excel BSp Liste.xlsx (Größe: 8,36 KB / Downloads: 3)
Antwortento top
#6
Moin

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDEFGHIJK
1Anzahl14
2KanditatenAnton
3
4
5abcdefg
6Antonabc17efg1Anton
7Maxabc13efg2Gustav
8Lisaabc2efg3
9Annaabc11efg4
10Gustavabc22efg5

ZelleFormel
K6=WENNFEHLER(INDEX(A:A;AGGREGAT(15;6;ZEILE($A$6:$A$10)/($E$6:$E$10>$B$1);J6));"")

ZelleGültigkeitstypOperatorWert1Wert2
B2Liste=$K$6:$K$10
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste