Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Drop Down Liste von Zelle abhängig machen
#1
Hallo zusammen,

ich möchte gerne folgendes in Excel erstellen:

In Zelle X trägt ein Benutzer eine bestimmte Zahl ein (jegliche beliebige Zahl).

In Zelle Y ergibt sich aus dieser Eingabe ein Dropdown Menü. Der Inhalt des Dropdown Menüs ist abhängig von Zelle X (Größer oder kleiner Null)

Praxisbeispiel:

In Zelle X wird die Kontostandveränderung für den Monat händisch eingegeben. In Zelle Y sind nun verschiedene Gründe dafür in Form eines Dropdown Menüs auswählbar.

1. Wenn der Kontostand nun angewachsen ist (also der Wert in Zelle X größer als 0 ist), kann der Benutzer folgende Gründe in Zelle Y angeben:

a. Bonuszahlung
b. Urlaubsgeld
c. Sparsam

2. Wenn der Kontostand nun gesunken ist (also der Wert in Zelle y kleiner als 0 ist), kann der Benutzer folgende Gründe in Zelle Y angeben:

a. Autokauf
b. Investition
c. Sonderausgaben

Vielen Dank für eure Hilfe im Voraus!

Nurkris
Antwortento top
#2
Hola,

du schreibst die jeweiligen Gruppen untereinander, z.B. in H1:H3 und I1:I3.
In der Datenüberprüfung wählst du dann bei "Zulassen" Liste aus.
Hier dann folgende Formel:

Code:
=WENN(B1>0;$H$1:$H$3;$I$1:$I$3)

B1 ist deine Zelle X.

Gruß,
steve1da
Antwortento top
#3
Weil ich gerade eine "bekloppte" Lösung hatte, will ich die der Allgemeinheit mal nicht vorenthalten.  Blush

ABCDEF
1-6AD
2BE
3CF
4G

ZelleGültigkeitstypOperatorWert1Wert2
B1Liste=@INDEX(D:F;;VORZEICHEN(A1)+2)
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antwortento top
#4
Danke! KlapptSmile
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste