Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Datum-Formel
#1
Servus!

Ich brauch für ein Excel eine Datums Formel die mir immer das Datum des Dienstag der Woche ausgiebt außer in Wochen wo der Monatsletzte ist. 
Da soll mir der Monatsletzte ausgegeben werden und das für die letzten 4-5 Wochen.

Bsp.:
Wenn ich heute das Excel öffnen würde sollten mir folgende Daten angezeigt werden. 

20.10.2020
13.10.2020
06.10.2020
30.09.2020
22.09.2020


Vielen Danke im Vorraus!!!

PS.: bin noch etwas ein Excel Anfänger, sorry... Angel
Antwortento top
#2
Hallo

mega Formel in B1: 
Code:
=WENN(MONATSENDE(HEUTE()-((ZEILE(A1)-1)*7)-WOCHENTAG(HEUTE()-((ZEILE(A1)-1)*7);11)+2;0)-(HEUTE()-((ZEILE(A1)-1)*7)-WOCHENTAG(HEUTE()-((ZEILE(A1)-1)*7);11)+2)<7;MONATSENDE(HEUTE()-((ZEILE(A1)-1)*7)-WOCHENTAG(HEUTE()-((ZEILE(A1)-1)*7);11)+2;0);HEUTE()-((ZEILE(A1)-1)*7)-WOCHENTAG(HEUTE()-((ZEILE(A1)-1)*7);11)+2)

bis zu B5 kopieren

LG UweD
[-] Folgende(r) 1 Benutzer sagt Danke an UweD für diesen Beitrag:
  • Moto
Antwortento top
#3
Vielen Dank für deine Antwort UweD, auf die Formel wäre ich selbst nie gekommen!

Ich habe leider nur ein Problem, auf meinem MAC Excel 2019 funktioniert die Formel ohne Problem. Aber bei mir in der Arbeit auf Windows Excel 2010 nicht, es bleibt einfach nur die ganze Formel angezeigt.
Habe verschiedenste Dinge versucht um das Problem zu finden, leider ohne Erfolg...
Antwortento top
#4
Hallo,

ist die Zelle zufällig als Text formatiert? In Standard ändern.
Cadmus
[-] Folgende(r) 1 Benutzer sagt Danke an Cadmus für diesen Beitrag:
  • Moto
Antwortento top
#5
[ Bild bitte als Datei hochladen! ]

Nein habe es schon mit verschiedesten Zellen Formationen versucht, so sieht es aus.


Angehängte Dateien Thumbnail(s)
   
Antwortento top
#6
Hallöchen,

wenn DU das Zellformat geändert hast musst Du die Formel ggf. nochmal mit ENTER bestätigen ...
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
[-] Folgende(r) 1 Benutzer sagt Danke an schauan für diesen Beitrag:
  • Moto
Antwortento top
#7
Vielen dank für eure Hilfe habe es gestern endlich geschafft die Formel zum laufen zu bringenSmile

Ich muss es jetzt nur noch schaffen, dass mir falls der Monatsende auf ein Wochenende fällt, mir der letzte Wochentag vor Monatsende ausgegeben wird. 

LG
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste