Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Datenüberprüfung - Gültigkeitsregeln
#1
Hallo zusammen,

ich stehe vor folgendem Problem:

Ich habe in meiner Tabelle in Spalte A drop downs, mit denen man entweder "X"  od. "-" auswählen kann. "-" kann beliebig oft in der gleichen Spalte stehen, aber "X" darf nur ein mal ausgewählt bzw eingetragen werden.

Hab schon diverseste bedingte Formatierungen versucht, bin aber leider kläglich gescheitert...

Kann mir jmd. damit helfen?

Wie immer vielen Dank vorab & Viele Grüße
SteBen
Antwortento top
#2
Hola,


Code:
=(ZÄHLENWENN($A$2:$A$20;"x")>1)*(A2="x")

Gruß,
steve1da
Antwortento top
#3
Hallo,

Code:
=WENN(ZÄHLENWENN(A2:A15;"X")>1;"X darf nur einmal auftauchen";"passt alles")

EDIT: Da war wohl jemand schneller Tongue
Gruß

Stoffo
Antwortento top
#4
Hallo


- A1:A10 markieren
- Daten, Datentools, Datenüberprüfung
- Zulassen: Benutzerdefiniert
- Formel:
Code:
=(ZÄHLENWENN($A$1:$A$10;"X")<=1)*((A1="X")+(A1="-"))

- Dann den Fehlermeldungstext noch anpassen.
- Ok


LG UweD
Antwortento top
#5
Danke Euch für die Lösungen. Läuft, wie gewünschtSmile

jetzt habe ich doch noch mal eine Frage... ich habe pro Kalendertag eine Spalte.

Ich habe die Formel für mich wie folgt angepasst..

=(ZÄHLENWENN($L$4:$L$53;"X")<=1)*((L4="X")+(L4="-"))

Gibt es eine Möglichkeit, dass ich diese auf die übrigen 364 Spalten übertragen kann & sich die Spalten entsprechend automatisch anpassen?

Habs schon mit Gültigkeit übernehmen versucht, aber das klappt nicht, dann kann man wieder Doppeleingaben tätigen...

Danke Euch 

VG
SteBen
Antwortento top
#6
Hallo,

google mal absolute und relative bezüge.
Gruß

Stoffo
Antwortento top
#7
Hallo nochmal

dann musst du die $-Zeichen vor L weglassen

also: 
Code:
=(ZÄHLENWENN(L$4:L$53;"X")<=1)*((L4="X")+(L4="-"))


LG UweD
[-] Folgende(r) 1 Benutzer sagt Danke an UweD für diesen Beitrag:
  • SteBen
Antwortento top
#8
Danke, klapptSmile

Noch eine & hoffentlich die letzte Frage dazu..

Wie muss ich die Formel denn umstellen, wenn ich erreichen möchte, dass max. 4x "X" pro Zeile eingetragen werden kann?

Habs wie folgt versucht, aber ich kann trotzdem noch beliebig oft "X" eintragen..

=(ZÄHLENWENN($L4:$EC4;"X")<=4)*((L4="X")+(L4="-"))

Vielen Dank vorab 

VG
SteBen
Antwortento top
#9
Hallo

bei mir klappt es so.

Du musst den Bereich L4:EC4  (oder auch weiter nach unten) markieren, beginnend in L4

Dann bei aktiver Zelle L4 die Formel eintragen


LG UweD
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste