Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Daten aus Liste auswählen und kopieren
#1
Hallo ins Forum,

ich habe schon bei Google und auch hier gesucht, vermutlich nutze ich einfach die falschen Suchwörter. Ich kann mir fast nicht vorstellen dass mein Vorhaben so ungewöhnlich istSmile Daher bitte ich euch um Hilfe.

Ich möchte aus einer feststehenden Tabelle mehrere Zellen in einer Zeile an eine andere Stelle Kopieren wenn die entsprechende Zeile gefunden wurde.

Also als Beispiel:

Ich weis, dass ich für 1 bis 4 Personen 1 Tisch und 4 Stühle brauche und das ich für 5 bis 8 Personen 2 Tische und 8 Stühle brauche usw. Das ganze habe ich in einer Tabelle hinterlegt (Das ist nur ein Beispiel, welches natürlich auch berechnet werden könnte, das ist aber für meinen etwas komplexeren Fall nicht möglich)

Ich möchte jetzt in eine Zelle zb die Anzahl 6 eingeben und das Excel jetzt die Passende Zeile "sucht" und dann eben "2 Tische" "4 Stühle" (Es ist durchaus Text dabei) An ein anderes Ziel (natürlich in der vorgegeben Reihenfolge) kopiert. Die Quelle und Ziel Zellen sind zudem geschützt, nur die Zelle mit der eingegeben Anzahl 6 ist frei.

Wäre echt Super wenn ich das Problem hier lösen könnte.

Bitte nachfragen wenn etwas unklar ist

Viele Grüße
McQuade
Antwortento top
#2
Hi,

stell uns bitte eine Beispieltabelle (.xlsx - keine Bildchen!!) vor. So geht's Hochladen: https://www.clever-excel-forum.de/Thread...ng-stellen
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#3
Kein ProblemSmile
.xlsx   Beispiel Stühle Tische.xlsx (Größe: 8,5 KB / Downloads: 4)
Antwortento top
#4
Hi,
auf die Beispieltabelle bezogen:

Tabelle1
CD
15Zielort
162 Tische8 Stühle
173 Tische12 Stühle
183 Tische12 Stühle
19
20

 verbundene Zellen
C15: D15

verwendete Formeln
Zelle Formel Bereich N/A
C16:C20=WENNFEHLER(SVERWEIS(B5+3;$K$10:$M$13;2;1);"")
D16: D20=WENNFEHLER(SVERWEIS(B5+3;$K$10:$M$13;3;1);"")
http://excel-inn.de/dateien/vba_beispiel..._addin.zip
http://Hajo-Excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 25.21 einschl. 64 Bit

Cadmus
Antwortento top
#5
HiSmile

Danke für diese Lösung, leider habe ich in meiner "original" Tabelle bei der Anzahl auch unregelmäßige "Sprünge" in der Spalte K. Die Spalte J wurde ja bei deiner Lösung wohl nicht abgefragt.

Gibt es da noch eine Verbesserung?
Antwortento top
#6
(15.05.2020, 21:56)McQuade schrieb: HiSmile

... leider habe ich in meiner "original" Tabelle ...
Gibt es da noch eine Verbesserung?

Ja, eine Datei posten, die im Aufbau dem Original entspricht... Das kann doch nicht schwer sein...
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
Antwortento top
#7
Zitat:Die Spalte J wurde ja bei deiner Lösung wohl nicht abgefragt.


Hallo,
war bei der Gestaltung des Beispiels auch nicht notwendig.

Wenn die Beipiele nicht den tatsächlichen Verhältnissen entsprechen, ist das nicht mein Problem.
Cadmus
Antwortento top
#8
Tja, dann trotzdem Danke.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste