Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Buchstaben zählen und auslassen
#1
Hallo Community,
folgende Problematik.

Ich habe im Excel für das gesamte Jahr 2021 eine Urlaubsübersicht erstellt.
Hier werden dann mit "U" mit Urlaub eingetragen und koordiniert.
Pro "U" sind 8 Stunden zu zählen und dann als Summe auszugeben, das habe ich mal so defininiert:

=WENN(C8="U";8;0)

und das funktioniert ganz gut.

Jetzt habe ich aber noch folgendes Problem - die U werden ja so eingetragen, dass auch die Samstag, Sonntage und Feiertage enthalten sind, für die dürften aber keine 8 Stunden gerechnet werden.
Diese Tage sind auch in einer Zeile als Sa, So, Ft angeführt.

Schaffe ich es, dass ich der Formel sage - wenn ich U eintrage, rechne mir bitte 8 Stunden, wenn aber in der Zeile "so und so" Sa, So oder Ft steht, dann wird da nichts gerechnet.

danke
Antwortento top
#2
Hallo, guten Morgen
Du musst halt alle Bedingungen für 8 / 0 Stunden definieren
Sinngemäß: =oder(A8="Sa";A8="So";A8="Ft";C8<>"U")
Besser noch du könntest das Datum und eine Liste der Feiertage abfragen. Dann könnte Nettoarbeitstage() ins spiel kommen.

könntest du sonnst bitte definieren wo in der Zeile Sa / So / Ft steht.
Am besten ist ein Beispiel in forme einer Excel Datei anzuhängen.
Da kann man die Hilfe vorher selbst mal testen.

Gruß Holger
Antwortento top
#3
=8*UND(A8<>"Sa";A8<>"So;A8<>"Ft";C8="U")
Schöne Grüße
Berni
Antwortento top
#4
oder:
ABCDEFGH
1MoDiMiDoFrSaSoFt
2UUUUUU
3888000

ZelleFormel
A3=WENN(A2="U";8-8*ISTZAHL(FINDEN(A$1;"SaSoFt"));"")

Gruß Ralf

… und falls die 0 stört, kann man sie per Zahlenformat Standard;; "unsichtbar" machen …

noch etwas verkürzt:
=(A2="U")*(8-8*ISTZAHL(FINDEN(A$1;"SaSoFt")))
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antwortento top
#5
Wobei unbedingt noch erwähnt sei, dass 8 in diesem Kontext falsch ist, da hier 8 volle Tage gezählt werden. Für 8 Stunden gilt daher eine der obigen Formeln abgewandelt auf 
8/24
Schöne Grüße
Berni
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste