Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Bestand aus Spalte in Zeile in anderer Tabelle einfügen
#1
Hallo Zusammen, 

ich hoffe sehr ihr könnt mir helfen. Schonmal vielen Dank!

Ich habe 2 Tabellen die wie folgt aussehen:

1.Tabelle:

Artikelnr. Artikelbezeichnung XS S M L XL
1234       Artikel 1                       6     2
5678         Artikel 2                 1      3  4 

2. Tabelle:
Artikelnr.       Artikelbezeichnung      Bestand 
1234          Artikel 1 
1234 - XS
1234- S
1234- M
1234 - L
1234- XL


ich habe also von einem Artikel 1 Varianten erstellt. Jetzt soll aus Tabelle 1 der Bestand in Tabelle 2 eingefügt werden. Sollte also danach so aussehen:

Artikelnr.       Artikelbezeichnung      Bestand 
1234          Artikel 1 
1234 . XS
1234- S
1234- M                                        6
1234 - L
1234- XL                                       2



Dies würde ich gerne über eine Formel lösen. Da dies mir circa 5000 Produkten gemacht werden muss.

Vielen Dank nochmal und liebe Grüße
Antwortento top
#2
Hola,

eine Beispieldatei (kein Bild) wäre hilfreich.

Gruß,
steve1da
Antwortento top
#3

.xlsx   Bespiel.xlsx (Größe: 6,54 KB / Downloads: 3)

vielen Dank für die schnelle Antwort, anbei die Bespieldatei
Antwortento top
#4
Hola,

ist der Aufbau zwingend vorgegeben, also steht in Blatt 2 immer die Nummer mit der Größe in einer Zelle oder kann man das auf 2 Zellen verteilen?
Wenn nicht, sind die Daten nicht ganz eindeutig - manchmal ist vor dem "-" noch ein Leerzeichen, manchmal nicht. Wenn das immer gleich wäre, z.B. immer ein Leerzeichen vor und hinter dem Bindestrich, dann ginge das so:


Code:
=WENNFEHLER(SVERWEIS(LINKS(A3;FINDEN("-";A3)-2)*1;Tabellenblatt1!$A$1:$G$3;VERGLEICH(TEIL(A3;FINDEN("-";A3)+2;2);Tabellenblatt1!$A$1:$G$1;0);0);"")

Gruß,
steve1da
Antwortento top
#5
super, danke dir.  28 
Bei der Beispiel-Datei hat es super funktioniert, jedoch leider noch nicht der eigentlichen Tabelle. 

Aber das werde ich hoffentlich schon noch hinbekommen. 

LG
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste