Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Aus sortierter Spalte mit Leerzellen nur die Werte in anderer Spalte übernehmen
#1
Hallöchen,

ich möchte mit Bordmitteln, also ohne vba, aus einer Spalte mit Werten UND Leerzellen automatisch nur die Werte fortlaufend in eine andere Spalte übernehmen.
Also die Inhalte in Spalte A in Zeile  1, 2, 3, 5, 7, 10 in Spalte B in Zeile 1-6

Danke schon einmal vorab für Hilfe ???

Opa Oli
Antwortento top
#2
Hi Oli,

mit einer (ausblendbaren) Hilfsspalte:

Arbeitsblatt mit dem Namen 'Tabelle3'
ABC
1abcabc1
2defdef2
3ghighi3
4jkl
5jklmno5
6pqr
7mno7
8
9
10pqr10

ZelleFormel
B1=INDEX(A:A;WENN(ISTFEHLER(KKLEINSTE($C$1:$C$10;ZEILE(A1)));"";KKLEINSTE($C$1:$C$10;ZEILE(A1))))
C1=WENN(A1<>"";ZEILE();"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Jeder Fehler erscheint unglaublich dumm,
wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • opa_oli
Antwortento top
#3
Das funktioniert prima. Danke.

Wenn man es vor sich hat: da hätte man auch selbst darauf kommen können.

Schönen Abend noch und gute Gesundheit !

Opa Oli
Antwortento top
#4
... oder ohne Hilfsspalte:

Arbeitsblatt mit dem Namen 'Tabelle2'
AB
1abcabc
2defdef
3ghighi
4jkl
5jklmno
6pqr
7mno
8
9
10pqr

ZelleFormel
B1=WENNFEHLER(INDEX($A$1:$A$10;AGGREGAT(15;6;ZEILE($A$1:$A$10)/($A$1:$A$10<>"");ZEILE(A1)));"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.02] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Gruß
Fred
Antwortento top
#5
(29.04.2020, 22:12)Fred11 schrieb: ... oder ohne Hilfsspalte:
...
Gruß
Fred

Das wird beimTE nicht funktionieren...
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
Antwortento top
#6
Angenommen, Opi abonniert Excel:

B1: =FILTER(A:A;A:A<>"")
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste