Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Auf/Abrunden mit eigenen Regeln
#1
Hallo, ich muss Zahlen in einem Korridor zwischen 0 und 5 nach einer bestimmten Regel auf bzw. abrunden

2,78 wird 2,5
2,79 wird 3

2,28 wird 2
2,29 wird 2,5

welche formel kann ich hierfür nutzen
Antwortento top
#2
Hallo claudiushartmann,

eine Formel, wo du die Werte direkt abfragen kannst, kenne ich nicht.

Du könntest folgende Formel benutzen:
Code:
=WENN((A2-GANZZAHL(A2))<0,29;GANZZAHL(A2);WENN((A2-GANZZAHL(A2))<0,79;GANZZAHL(A2)+0,5;GANZZAHL(A2)+1))

wobei der abgefragte Wert in Zelle A2 steht.

Eine zweite Möglichkeit wäre, eine Funktion in VBA zu schreiben:

Code:
Public Function RundeSpezial(Wert, UntenGrade, MitteGrade) As Variant
Dim Ganzzahl As Double
Dim Nachkomma As Double

On Error GoTo Fehler

' Der Bereich ist veränderbar, bei Angabe von 0 werden deine Werte vor eingestellt.

If UntenGrade = 0 Then UntenGrade = 0.29
If MitteGrade = 0 Then MitteGrade = 0.79

Ganzzahl = Fix(Wert)
Nachkomma = Wert - Ganzzahl

If Nachkomma < UntenGrade Then Nachkomma = 0
If Nachkomma >= MitteGrade Then Nachkomma = 1
If Nachkomma >= UntenGrade And Nachkomma < MitteGrade Then Nachkomma = 0.5

RundeSpezial = Ganzzahl + Nachkomma
Exit Function

Fehler:
RundeSpezial = "#WERT"
End Function

Klar, das der Code noch optimiert werden kann, aber zur Anschauung sollte es reichen.
 
Gruß
turbomicha
[-] Folgende(r) 1 Benutzer sagt Danke an turbomicha für diesen Beitrag:
  • claudiushartmann
Antwortento top
#3
Hallo,

vielleicht reicht schon das: =GANZZAHL((A2+0,21)*2)/2

Gruß Uwe
[-] Folgende(r) 1 Benutzer sagt Danke an Kuwer für diesen Beitrag:
  • claudiushartmann
Antwortento top
#4
oder so:
=VRUNDEN(A2-0,04;0,5)

Gruß
Fred
[-] Folgende(r) 1 Benutzer sagt Danke an Fred11 für diesen Beitrag:
  • claudiushartmann
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste