Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Anwesenheitsliste erstellen
#1
Hallo, ich habe folgendes vor:

Ich führe eine Anwesenheits-/Einteilungsliste meiner Mitarbeiter. Die sieht folgendermaßen aus:

Spalte A ab Zeile 2 die Namen.
Spalte B ab Zeile 2 die Qualifikation (z.B. Mechaniker/Mechatroniker/Elektriker etc..)
Ab Spalte C steht in der ersten Zeile das Datum (das mache ich meist zwei drei Wochen im Voraus und lösche dann das wieder, was schon vorbei ist) und darunter dann der jeweilige Einsatzort pro Mitarbeiter an diesem Tag (Bereich 1/Bereich 2/Bereich 3 oder eben "Abwesend")

Zur besseren Übersicht, dachte ich, würde ich gerne für jeden Tag eine Anwesenheitsliste erzeugen, die ich ausdrucken kann. Sprich, ein separates Tabellenblatt, in dem ich oben das gewünschte Datum eintrage und sich dann eine Anwesenheitsliste generiert mit Spalte A Namen, Spalte B Qualifikation, Spalte C Bereich. Wichtig jedoch, dass dort nur diese Mitarbeiter auftauchen, die an diesem Datum NICHT "Abwesend" sind. 

Also müsste sich diese Tabelle 2 automatisch die Spalte von Tabelle 1 auswählen, die dem eingetragenen Datum entspricht und aus dieser Spalte nur Mitarbeiter übernehmen, die nicht abwesend sind... Wie lässt sich sowas ohne großen Aufwand realisieren?

Vielen Dank im Voraus!
Antwortento top
#2
Hola,

eine Beispieldatei (kein Bild) wäre hilfreich.

Gruß,
steve1da
Antwortento top
#3
So, schnell mal zusammengeschustert, sollte aber reichen... 

Wenn im roten Feld in Tabelle 2 das Datum eingetragen wird, sollte sich der Rest unten automatisch, basierend auf den Daten aus Tabelle 1 ausfüllen...
.xlsx   Mappe.xlsx (Größe: 11,48 KB / Downloads: 14)
Antwortento top
#4
Hola,


Code:
=WENNFEHLER(INDEX(Tabelle1!A:A;AGGREGAT(15;6;ZEILE(Tabelle1!$A$2:$A$11)/((Tabelle1!$C$1:$K$1+0=$D$3)*(Tabelle1!$C$2:$K$11<>"abwesend"));ZEILE(A1)));"")

Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • Ivan1862
Antwortento top
#5
Hi,
keine Ahnung, warum, aber Steves Formel funktioniert bei mir nur, wenn das "+0" weggelassen wird.
Gruss, Raoul.
Antwortento top
#6
@Raoul: in Ivans Liste? Dort ist das Datum in der intelligenten Tabelle in der Überschrift und somit automatisch TEXT. Deshalb das +0, weil ich davon ausgehe dass in D3 ein ZAHL Datum eingetragen wird.

Gruß,
steve1da
Antwortento top
#7
Hallo,

erstens: vielen Dank, die Formel funktioniert super, genau so, wie sie oben steht.. Echt super!

Nur nun noch eine Frage: Wie mache ich es, dass in Tabelle 2, Spalte 3 (Bereich), nicht eine bestimmte Spalte (z.B A:A), sonder eben immer die Spalte ausgewählt wird, die dem eingetragenen Datum entspricht?
Antwortento top
#8
Hallo Steve,

hab's nochmals ausprobiert.

Wenn man in das Datumsfeld der Tabelle2 ein Datum EINTRÄGT, wie es auch in der Frage beschrieben ist und wie es auch jeder tun würde, dann funktioniert Deine geniale Formel bestens.

Deine Formel liefert dann keine Ergebnisse, wenn man aus der Kopfzeile der intelligenten Tabelle (C1:K1) ein Datum KOPIERT und in das Datumsfeld der Tabelle2 einfügt. Daher meine Fehleinschätzung. Entschuldige die Störung und danke für die Info.

Gruss, Raoul
Antwortento top
#9
Hola,

@Raoul: so etwas ist keine Störung sondern nützliche Hinweise!


Code:
=WENNFEHLER(INDEX(Tabelle1!C:K;AGGREGAT(15;6;ZEILE(Tabelle1!$A$2:$A$11)/((Tabelle1!$C$1:$K$1+0=$D$3)*(Tabelle1!$C$2:$K$11<>"abwesend"));ZEILE(A1));VERGLEICH($D$3;Tabelle1!$C$1:$K$1+0;0));"")

Gruß,
steve1da
Antwortento top
#10
Hallo,

vielen Dank erstmal noch für die Bemühungen!! In meiner Beispieldatei funktioniert das alles wunderbar, doch für meine eigentliche Datei wollte ich die Formel anpassen, leider ohne Erfolg...  Huh

Spalte A und B in der Anwesenheitsliste funktionieren ohne Probleme, nur die Spalte C will nicht? An was liegt denn das??  22


Angehängte Dateien
.xlsm   Anwesenheit.xlsm (Größe: 37,66 KB / Downloads: 5)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste