Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Anführungsstriche in FormulaLocal
#1
Guten Tag zusammen,

ich würde gerne folgende Formel über FormulaLocal in eine Zelle schreiben

Code:
=SUMMENPRODUKT(TEILERGEBNIS(3;INDIREKT("BP"&ZEILE(7:67)))*((AM7:AM67="A1/B1")+(AM7:AM67="A1/B2+")+(AM7:AM67="A1/B2")+(AM7:AM67="A2+/B1")+(AM7:AM67="A2+/B2+")+(AM7:AM67="PA/B1")))/TEILERGEBNIS(3;AM7:AM267)

da mit vba erstmal direkt einen error angezeigt kommt und ein plötzliches Anweisungsende dachte ich daran vllt die Gänsefüßchen doppelt zu machen (wie in anderen Sprachen)

Code:
ActiveSheet.Range("AR1").FormulaLocal = "=SUMMENPRODUKT(TEILERGEBNIS(3;INDIREKT(""BP""&ZEILE(7:67)))*((AM7:AM67=""A1/B1"")+(AM7:AM67=""A1/B2+"")+(AM7:AM67=""A1/B2"")+(AM7:AM67=""A2+/B1"")+(AM7:AM67=""A2+/B2+"")+(AM7:AM67=""PA/B1"")))/TEILERGEBNIS(3;AM7:AM267)"


allerdings hier auch kein Erfolg 

hat einer eine Idee?
Antwortento top
#2
Hallo,

abgesehen davon, das es meiner Ansicht nach keinen Sinn macht, Formalen per VBA in eine Liste einzutragen, weil man ja gleich mit VBA rechnen kann, kann ich mich dunkel erinnern, dass da bei der Summenproduktformel noch ein weiteres Hindernis gibt.
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
Antwortento top
#3
Hallo,

bei mir (Excel 2016) funktioniert Deine zweite Formel mit den doppelten Anführungszeichen.
Gruß Atilla
Antwortento top
#4
Bei mir geht es jetzt auchSmile
Danke euch, war wohl n Typo, nervig sowas...
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste