Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Aktuelle Jahr als Ergebnis
#1
Hallo,

könnte mir jemand zeigen, wie man das aktuelle Jahr ermitteln kann.



Habe es folgendermaßen gemacht:

=YEAR(TODAY())

Bedauerlicherweise wird folgendes ausgegeben: 16.07.1906

Dachte es würde 2024 als Ergebnis resultieren.
Antworten Top
#2
Moin!
Der 2024. Januar 1900 ist halt der 16.07.1905
(Schreibfehler bei Dir?) Idea

Formatiere auf Standard und staune.

A
116.07.1905
22024
316.07.1905

ZelleFormatWert
A1TT.MM.JJJJ16.07.1905
A3TT.MM.JJJJ16.07.1905

ZelleFormel
A1=JAHR(HEUTE())
A2=JAHR(HEUTE())
A3=DATUM(0;1;A2)

Gruß Ralf
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
[-] Folgende(r) 1 Nutzer sagt Danke an RPP63 für diesen Beitrag:
  • Murmelchen
Antworten Top
#3
super Danke!


könntest du mir noch sagen, wo hier der Syntax Fehler ist??

Wenn das Jahr von H6 dem aktuellen entspricht, dann soll fogende Formel angewandt werden ansonsten soll J6/M5 geteilt werden.

IF(YEAR(H6)=(YEAR(TODAY()); IFERROR(DATEDIF(MAX(EOMONTH($H6;-1);DATE(YEAR(H6);1;0));MIN(DATE(YEAR(H6)+1;1;1);DATE(YEAR($H6)+M6;MONTH($H6);1));"m")/$M6/12*$J6;0); 3 ); J6/M5)
Antworten Top
#4
Hi,

auf die Schnelle: Eine Klammer zuviel, nach dem =

IF(YEAR(H6)=YEAR(TODAY()); IFERROR(DATEDIF(MAX(EOMONTH($H6;-1);DATE(YEAR(H6);1;0));MIN(DATE(YEAR(H6)+1;1;1);DATE(YEAR($H6)+M6;MONTH($H6);1));"m")/$M6/12*$J6;0); 3 ); J6/M5)

Ansonsten: Datei, dann muß man nicht die ganze Formel übersetzen.
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antworten Top
#5
Folgendes liefert nun als Ergebnis #VALUE!

=IF(YEAR(H6)=YEAR(TODAY());IFERROR(DATEDIF(MAX(EOMONTH($H6;-1);DATE(YEAR(H6);1;0));MIN(DATE(YEAR(H6)+1;1;1);DATE(YEAR($H6)+M6;MONTH($H6);1));"m")/$M6/12*$J6;0);3);J6/M5

hab die Spalte auch als Zahl definiert.


Die Formel alleine funktioniert jedoch tadellos:

=IFERROR(DATEDIF(MAX(EOMONTH($H6;-1);DATE(YEAR(H6);1;0));MIN(DATE(YEAR(H6)+1;1;1);DATE(YEAR($H6)+M6;MONTH($H6);1));"m")/$M6/12*$J6;0)

Sobald es in der If Bedienung steht, erscheint die Fehlermeldung #VALUE!
Antworten Top
#6
Beachte das "Ansonsten:" von Edgar!
Auch mir fehlt die Lust, ohne Datei auf die Suche zu gehen.
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antworten Top
#7
Hallo,


anbei die Datei.


Angehängte Dateien
.xlsx   Datei.xlsx (Größe: 10,5 KB / Downloads: 6)
Antworten Top
#8
(08.06.2024, 10:30)Murmelchen schrieb: Die Formel alleine funktioniert jedoch tadellos:

=IFERROR(DATEDIF(MAX(EOMONTH($H6;-1);DATE(YEAR(H6);1;0));MIN(DATE(YEAR(H6)+1;1;1);DATE(YEAR($H6)+M6;MONTH($H6);1));"m")/$M6/12*$J6;0)

Dann übergeben wird der Einfachheit halber einfach 1 für obige Formel.
Deine Gesamtformel lautet jetzt:
=WENN(JAHR(H6)=JAHR(HEUTE());1;3);J6/5
Ich hoffe, Du siehst jetzt Deinen Fehler!
Sollte nicht statt 3 eher J6/5 in der Formel stehen?
=WENN(JAHR(H6)=JAHR(HEUTE());1;J6/5)
NOPQR
6736,16883,40883,40883,40
7571,67686,00686,00686,00
8378,15378,15378,15378,15
9176,46176,46423,502024423,50
10142,42142,42341,80341,80
11101,07101,07303,20303,20
1249,870,00598,40598,40
1346,120,00553,42553,42

ZelleFormel
R6=IF(YEAR(H6)=YEAR(TODAY()),
IFERROR
(DATEDIF(MAX(EOMONTH($H6,-1),
DATE
(YEAR(H6),1,0)),MIN(DATE(YEAR(H6)+1,1,1),
DATE
(YEAR($H6)+M6,MONTH($H6),1)),"m")/$M6/12*$J6,0),
J6/5)
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antworten Top
#9
20 20 20 20 

Hi,

ist Dir überhaupt mal aufgefallen, dass bei Deiner Formel, die Du vorhin gepostet hast und die auch so in Deiner Tabelle steht, außerhalb der If-Formel noch ein Teil steht?
Ist es so schwer die Formelauswertung zu benutzen oder mal genau hinzuschauen? Es dürfte jedem klar sein, dass nach einer If(....) nicht noch ;J6/M5 stehen darf!

Hier mal mein Vorschlag (korrigierte Version):


.xlsx   Datei.xlsx (Größe: 10,71 KB / Downloads: 4)
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antworten Top
#10
Kurzer Verweis auf das urspüngliche Thema:
https://www.clever-excel-forum.de/Thread...schreibnen
Gruß
Michael
Antworten Top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste