Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Adress-Liste
#1
Hallo zusammen,

ich benötige einmal Eure Hilfe bei einer Excel-Mappe.

Es handelt sich um eine Adress-Liste mit zusätzlichen Informationen.

Im ersten Tab sind derzeit etwa 90% aller Daten und Zeilen enthalten.

Im nächsten Tab sind jedoch mehr Adress-Zeilen.

Mein Gedanke war nun, dass ich die Daten im 2ten Tab einfach per "=X" einfüge... soweit ging das auch, hatte aber zur Folge, dass wenn ich auf Tab A sortiert habe, dass die Daten auf Tab B völlig durcheinander geraten sind :(

Frage ist nun, wie übernehme ich Daten aus Tab A ohne das es in Tab B auswirkungen auf die Sortierung hat.

Ich habe mal ein vereinfachtes Beispiel beigelegt.

Dank und
Gruß

ItsME
Antwortento top
#2
Hi,

da ist kein Beispiel; aber nach dem Hochladen musst du den roten Pfeil beachten!

Ich würde aber mit einer WENN/ZÄHLENWENN()-Formel in einer Hilfsspalte ein "x" eintragen lassen und mit INDEX/AGGREGAT() auslesen.
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#3
hoppla Confused


Angehängte Dateien
.xlsx   TEST-Tabelle.xlsx (Größe: 32,51 KB / Downloads: 10)
Gruß

ItsME
Antwortento top
#4
Hi,

du kannst in einer Spalte nicht Formeln und Werte mischen. Lass in der Tabelle mit den meisten Datensätzen (hier Tab2) nur die Werte stehen und hole die Daten (und zwar alle!!) dann nach Tab 1.

Mein Vorschlag:

Arbeitsblatt mit dem Namen 'Tab A'
ABCDEFGHIJ
3Lfd.Nr.Inhaber (Name/Firma)Geb.-DatumVertreterStraßePLZOrtDaten1Daten2Datum
4
51Firma 115.05.1950Tom ParisSchlossallee 315326Woauchimmer5Notiz 101.01.2020
62Firma 2-Kathrin JanewayAllstraße 1235656Hier5Notiz 201.01.1989
73Firma 3-James T. KirkEnterpriseallee 885659Dort5Notiz 315.05.1985

ZelleFormel
B5=WENNFEHLER(INDEX('Tab B'!C:C;AGGREGAT(15;6;ZEILE('Tab B'!$C$5:$C$131)/('Tab B'!$A$5:$A$131='Tab A'!A5);1));"")
D5=WENNFEHLER(INDEX('Tab B'!D:D;AGGREGAT(15;6;ZEILE('Tab B'!$D$5:$D$131)/('Tab B'!$A$5:$A$131='Tab A'!A5);1));"")
E5=WENNFEHLER(INDEX('Tab B'!E:E;AGGREGAT(15;6;ZEILE('Tab B'!$D$5:$D$131)/('Tab B'!$A$5:$A$131='Tab A'!A5);1));"")
F5=WENNFEHLER(INDEX('Tab B'!F:F;AGGREGAT(15;6;ZEILE('Tab B'!$D$5:$D$131)/('Tab B'!$A$5:$A$131='Tab A'!A5);1));"")
G5=WENNFEHLER(INDEX('Tab B'!G:G;AGGREGAT(15;6;ZEILE('Tab B'!$D$5:$D$131)/('Tab B'!$A$5:$A$131='Tab A'!A5);1));"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Wenn du die Überschriftenzeilen identisch aufbaust, kannst du die Formel nicht nur nach unten, sondern auch nach rechts ziehen. Benötigte zusätzliche Spalten ans Tabellenende anfügen.
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#5
Kleine Zwischenfrage, ItsME
zu den Namen und Adressen in Deiner Datei: Hast Du da eine Datenbank geklaut? Oder anders generiert?
Würde mich nur interessieren. Die Namen sind ja recht einfallsreich.
LG, Ralf
Antwortento top
#6
Hi,

vielen Dank für die schnelle Reaktion  19

Ich habe mir das angesehen...

Das, was in Tab A steht, ist abhängig von Tab B "Status", d.h. wenn dort z.B. "Wahl 1" ausgewählt ist, muss es in Tab A erscheinen (hatte ich vergessen zu erwähnen).

Problem ist nur, dass Tab A für offizielle Dinge gebraucht (Steuerberater etc.), daher muss ich diesen Tab quasi rauslösen können (würde einfach alle anderen Tabs löschen und neu abspeichern).

Wenn Tab A aber automatisch "befüllt" wird, haut das nicht mehr hin, zudem würde es u.U. Leerzeilen geben :(

Es ist tricky, ich geb's zu... 20

Ein Traum wäre, wenn ich alle Adressen in Tab B eintrage und diese in Abhängigkeit von "Status" in Tab A wandern und dort manuell um Daten ergänzt werden könnten, ohne Leerzeilen etc.; und ich anschließend Tab A herauslösen und/oder drucken kann (man wird ja noch träumen dürfen.. hehe). Aber ich denk, das ist gar nicht möglich.

(19.05.2020, 12:18)Raoul21 schrieb: Kleine Zwischenfrage, ItsME
zu den Namen und Adressen in Deiner Datei: Hast Du da eine Datenbank geklaut? Oder anders generiert?
Würde mich nur interessieren. Die Namen sind ja recht einfallsreich.
LG, Ralf
hehe.. die hab ich mir naja.. ausgedacht.. sind einige Trekki-Namen  Blush
Gruß

ItsME
Antwortento top
#7
Hi,

kommt das deinem Traum näher?
Code:
=WENNFEHLER(INDEX('Tab B'!C:C;AGGREGAT(15;6;ZEILE('Tab B'!$C$5:$C$131)/('Tab B'!$A$5:$A$131='Tab A'!A5)/('Tab B'!$H$5:$H$131="Wahl 1");1));"")

Aber wie ich bereits schrieb:
Zitat:du kannst in einer Spalte nicht Formeln und Werte mischen.
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top
#8
Hi,


Zitat:du kannst in einer Spalte nicht Formeln und Werte mischen.

versteh ich... und würde ja auch andersrum passen...

Sprich, wenn ich ALLE Daten in Tab B packe und mir auf Tab A alle mit dem richtgen Status anzeigen lassen könnte...


Zitat:kommt das deinem Traum näher?
Tatsächlich jaSmile


Hab das grad probiert, sieht schon gut aus... Daten von Tab B werden auf Tab A übertragen, wenn Bedingung erfüllt ist.

Leider kann ich dann Tab A nicht sortieren, damit leere Zeilen gar nicht erst auftauchen... oder am Ende... Excel erkennt scheinbar den Inhalt trotzdem und sortiert den mit :( D.h. die Nummerierung haut dann nicht mehr hin  92
Aber das ist naaaah dran Smile
Gruß

ItsME
Antwortento top
#9
Hi,

mir ist grad etwas aufgefallen...

Wenn ich Tab A sortiere, hat das Einfluß auf Tab B Huh
Gruß

ItsME
Antwortento top
#10
Das ist bei Formel-Abhängigkeiten in der Regel so. Wink
Gruß Günter
Jeder Fehler erscheint unglaublich dumm, wenn andere ihn begehen.
angebl. von Georg Christoph Lichtenberg (1742-1799)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste