Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Abrunden auf Ziffer
#1
Hallo,

ich erhalte durch eine Bruch-Aufgabe eine krumme Ziffer, und will nun in einer neuen Zelle ein ganze Zahl haben, die die nächstenkleinere Zahl ist, die eine 9 in der letzten Stelle hat.

Beispiel 370, 73  die 369 wäre jetzt die gerundete Zahl... Hat jemand eine Idee?
Antwortento top
#2
Hallo,

ich weiß nicht, wie du auf 369 kommst. Das liefern die Standardfunktionen von Excel:

Tabelle2

AB
2370,73371
3371
4370
Formeln der Tabelle
ZelleFormel
B2=RUNDEN(A$2;0)
B3=AUFRUNDEN(A$2;0)
B4=ABRUNDEN(A$2;0)

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
Antwortento top
#3
So?
Code:
=WENN(--RECHTS(ABRUNDEN(A1;0))=9;ABRUNDEN(A1;0);ABRUNDEN(A1;-1)-1)
Schöne Grüße
Berni
Antwortento top
#4
Hallo Berni,

perfekte Formel!
Aber noch eine Kleinigkeit: Bei Beträgen unter 9 kommt bei dir -1 heraus! Das solltest du noch abfangen.

Sigi
Antwortento top
#5
Bevor ich das mache, muss der TE erst mal sagen, ob es überhaupt notwendig ist. Denn eine Zahl < 9 auf den nächsten Wert mit 9 am Ende abzurunden, erscheint mir wenig sinnvoll.
Schöne Grüße
Berni
Antwortento top
#6
Ungetestet und auch mit -1 für Zahlen >= 0 und < 9:
=ABRUNDEN(A1+1;0)-1
Antwortento top
#7
Hallöchen,

sollen eigentlich 9, 19 usw. auch abgerundet werden oder bleiben?

Arbeitsblatt mit dem Namen 'Tabelle1'
AB
1370,73369
2368359
3199
490
530

ZelleFormel
B1=MAX(UNTERGRENZE(A1;10)-1;9*--(A1>9))
B2=MAX(UNTERGRENZE(A2;10)-1;9*--(A2>9))
B3=MAX(UNTERGRENZE(A3;10)-1;9*--(A3>9))
B4=MAX(UNTERGRENZE(A4;10)-1;9*--(A4>9))
B5=MAX(UNTERGRENZE(A5;10)-1;9*--(A5>9))
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#8
Ich hätte auch wie Sulprobil geantwortet, allerdings als B1: =ABRUNDEN(A1+1;-1)-1 (Zehnerrundung).

Man könnte da ein MAX(;...) drum ranken, aber dann behandelt man den Mini-Sonderfall von 0-<9 ... und das muss ja nun nicht wirklich sein. Ok: Für viele schon.

Schauan: Die Frage ist wohl einfach "die Verschiebung der Zehner auf einen niedriger als eben den Zehner". Also: Neun bleibt Neun, 8,9 geht runter auf Neun.
Antwortento top
#9
Ich danke allen. Was für Werte unter 9 kommen sollen, ist erst mal uninteressant.
Antwortento top
#10
Hallöchen,

Zitat:Die Frage ist wohl einfach "die Verschiebung der Zehner auf einen niedriger als eben den Zehner". Also: Neun bleibt Neun, 8,9 geht runter auf Neun.
... auch kein Problem

Arbeitsblatt mit dem Namen 'Tabelle1'
AB
1370,73369
2368359
31919
499
530

ZelleFormel
B1=MAX(UNTERGRENZE(A1+1;10)-1;9*--(A1>9))
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.2) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste