Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

3 WENN DANN Vorgaben
#1
Hallo zusammen,

ich bin dabei eine etwas größere Tabelle mit Termin zu erstellen, dabei möchte ich folgendes darstellen:
zu einem bestimmten Datum müssen Untersuchungen durchgeführt werden, die Zeit die für die Untersuchung zur Verfügung steht hängt vom Alter der Probe ab.

Beispiel: Probe 1 ist fällig am 05.10.2020 die Probe ist 3 Monate alt, daher beträgt die Zeit für die Analytik 41 Tage (also bis zum 15.11.2020)
Bis jetzt habe ich die Formel händisch eingefügt, da die Anzahl an Muster aber stetig steigt, würde ich das gerne über eine Formel abbilden.
Ein Beispiel und die zulässigen Zeiten, für jeden Prüfzeitpunkt habe ich einer Beispieltabelle hinterlegt.
Der Prüfzeitpunkt wird immer mit Tx (wobei x eine Zahl ist) dargestellt. 
Die Herausforderung ist zum einen, dass es 3 WENN Bedingungen gibt und zum anderen das größer/gleich und das kleiner/gleich Zeichen.


Ich hoffe ich habe mein Problem verständlich beschrieben.
Vielen Dank schonmal für Eure Unterstützung.

Claudia


Angehängte Dateien
.xlsx   Prüfdatum.xlsx (Größe: 8,91 KB / Downloads: 9)
Antwortento top
#2
Moin

Frage: Ist T1 dann gleich 20 Tage, T2 gleich 27 Tage und T3 gleich 41 Tage?
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#3
Hallo,

nicht schön aber funktional:
PHP-Code:
=WENN(B3="T1";C3+20;WENN(B3="T2";C3+27;WENN(B3="T3";C3+41;"Kein Tx bestimmt"))) 

dann einfach nach unten ziehen.

Die Schwierigkeit mit größer und kleiner gleich kann ich nicht ganz nachvollziehen, da hierfür meiner Meinung nach ein Ausgangswert (Prüftag) fehlt. Welcher deiner Werte ist denn gegeben und welcher soll ermittelt werden? In meiner Formel gehe ich davon aus, dass du den Spätesten Prüftermin ermitteln willst. Dementsprechend wäre die Formel in E2 einzufügen.
Gruß

Stoffo
Antwortento top
#4
Hallo zusammen,

vielen Dank für die Antworten.
Ich hatte versucht mein Problem etwas vereinfacht darzustellen, hatte aber einen Knoten in meinen Gedanken,, da ich mich von meinen Vorgaben habe verwirren lassen.
Der Vorschlag von Stoffo funktioniert zwar für 3 Zeitpunkte, aber bei 60 wird es dann schwierig.

In meiner Tabelle ist das Datum in Spalte C gegeben, und es soll der späteste Prüftermin in Spalte D ermittelt werden.
Der späteste Termin ist davon abhängig wie wie alt die Proben sind, das Alter wird in Spalte B mit T1 bis insgesamt T60 angegeben.
Ist eine Probe 1 - 4 Monate alt gilt: Datum Spalte C + 20
Ist eine Probe 5 - 9 Monate alt gilt: Datum Spalte C + 27 
Ist eine Probe 10 - 60 Monate alt gilt: Datum Spalte C + 41

So dürfte mein Problem mit dem größer/gleich und kleiner/gleich vielleicht auch verständlich werden.
Antwortento top
#5
Hola,

das passt jetzt aber nicht mehr zu den Vorgaben in der Tabelle...


Code:
=WENN(RECHTS(B2)*1<=4;C2+20;WENN(RECHTS(B2;1)*1<=9;C2+27;C2+41))

Gruß,
steve1da
Antwortento top
#6
Hi,

=C1+VERWEIS(WECHSELN(B1;"T";"")*1;{1;5;10};{20;27;41})
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#7
Moin steve1da,

Vielen Dank für die Hilfe!
Leider klappt das mit der Formel noch nicht so ganz, die Formel unterscheidt nur zwischen T1 - T9, wenn ein Wert T10 - T60 als Zeitpunkt erscheint, wird nur die letzte Zahl (zb bei 14, wird die 4 bewertet), ich denke es fehlt ein Zusatz, dass es 2 stellige Zahlen in B2 gibt. 

Gruß
claudia
Antwortento top
#8
Hola,


Code:
=WENN(LÄNGE(B2)=3;C2+41;WENN(RECHTS(B2)*1<=4;C2+20;C2+27))

Gruß,
steve1da
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste