Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

3 Kriterium Verweis! Für Fortgeschrittene
#1
Hallo Liebe Excel Freunde, 

ich muss aus einer Tabelle einen Wert auslesen. Dabei gibt es 3 Kriterien zur Auswahl. Ich habe mich mal mit einem Sverweis rangesetzt, allerdings funktioniert dieser nicht. 
Vlt fällt euch eine Lösung dazu ein=)

Viele Grüße
Max


Angehängte Dateien
.xlsx   TemplateGamma_Values_V2.xlsx (Größe: 42,51 KB / Downloads: 11)
Antwortento top
#2
Hola,

Code:
=SUMMENPRODUKT((C5:C528=N7)*(D5:D528=N6)*(F4:J4=N5);F5:J528)

Gruß,
steve1da
Antwortento top
#3
Hallo, was spricht denn gegen eine Datenbankfunktion..?
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
Antwortento top
#4
Besten Dank für die schnelle Antwort!

Was ist den eine Datenbankfunktion?
Antwortento top
#5
Hallo, das könnte man googlen...
https://support.office.com/de-de/article...dc023f5c23
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
Antwortento top
#6
PHP-Code:
=INDEX(A1:K100;MATCH(N7&N6;C1:C100&D1:D100;0);MATCH(N5;A4:K4;0)) 
Zum übersetzen von Excel Formeln:

http://dolf.trieschnigg.nl/excel/index.p...gids=en+de
Antwortento top
#7
Ich habe mal einen Wert eingetragen und auf die Schnelle eitwas auf einem anderen Blatt gebastelt..: (das geht natürlich eleganter..., aber ich gebe mir nicht mehr Mühe als du)

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDEFGHIJ
1NameScenarioUnitDeveloping urban powerhousesHigh-compact middleweightsProsperous innovation centersHigh-density megacitiesCar-centric giants4
2Driven km of robo podBC 1850

ZelleFormel
J1=VERGLEICH(InputSimulation!N5;Tabelle1!A1:H1;0)
A2=InputSimulation!N7
B2=InputSimulation!N6
J2=DBSUMME(InputSimulation!C4:J528;J1;Tabelle1!A1:H2)
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.01] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste