Das Clever-Excel-Forum.de - Treffen
findet vom 15. - 17. September 2017 in Thüringen / Region Großer Inselsberg statt. Hotelbuchung ab sofort möglich.


Index mit Vergleichen
#1
Hallo allerseits

Habe noch ein grosses Problem..

In der Datei gibt es das Blatt "Schiri Navi". Dort trage ich händisch die Distanzen ein, die Ein Schiri braucht um von A nach B zu kommen.
In Abhängigkeit vom Spielort (Zeilen A und B) und dem Schiri Namen (Zeile F)
soll in Spalte AV des Blattes "Auslagen" die richtige Distanz eingetragen werden.
In den Auslagen ist ebenfalls Schiri Name ausschlaggebend, zudem kann daraus geschlossen werden, wenn eine Zahl in der gleichen Zeile von D:AU steht, dass der Ort aus Zeile 3 gesucht wird.

Habe aber die andern Sheets auch mitgesendet, vielleicht muss man das ja anders verknüpfen.
Ich habe es bereits geschafft, diese Verknüpfung hinzubekommen, siehe Blatt Aufgebot2, C20. Das funktioniert aber bei Auslagen AV nicht, die zweite Bedingung fehlt...

Herzlichen Dank und einen schönen Abend Angel

Dänel


Angehängte Dateien
.xlsx   Bezüge mit versch. Variablen.xlsx (Größe: 506,68 KB / Downloads: 9)
to top
#2
(02.05.2014, 16:32)Daenel schrieb: Hallo allerseits

Habe noch ein grosses Problem..

...

Dänel

hi, ist denn das andere problem gelöst...? ich sehe kein feedback von dir...
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#3
Hallo Jockel

Bist du hier der Polizist?

Ich tue, was ich kann, und antworte so schnell ich kann. Du scheinst irgendwie ein Problem zu haben.

Lass dich nicht unterkriegen, das leben ist schön.

Liebe Grüsse
Dänel
to top
#4
(02.05.2014, 16:53)Daenel schrieb: Hallo Jockel

Bist du hier der Polizist?

Ich tue, was ich kann, und antworte so schnell ich kann. Du scheinst irgendwie ein Problem zu haben.

Lass dich nicht unterkriegen, das leben ist schön.

Liebe Grüsse
Dänel

hi, nein, ich bin kein polizist, aber du ballerst aus der hüfte... anstatt ein problem abzuarbeiten, dann das nächste zu präsentieren... aber okay, wenn das deine arbeitsweise ist...
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#5
Hallo Jockel

Wenn ich zwei Probleme habe, die im Prinzip nichts miteinander zu tun haben, dann glaube ich, dass ich die schon gleichzeitig Posten kann. Ich bin ja froh, gibt es Cracks wie dich, die solche Probleme lösen können.

Vielleicht kann der eine Dies und der andere Jenes.

Ja, so arbeite ich.

Dänel
to top
#6
hi, vielleicht verstehe ich das problem auch nicht... ich sehe in der datei (zu) viele baustellen... für die formel in C20 schlage ich alternativ die in C21 vor...:

Arbeitsblatt mit dem Namen 'AUFGEBOT2'
 ABC
19SchiedsrichterTaggeld
(CHF) *)
Fahrspesen
(CHF) **)
20Meier Daniel30,000,00
21Gugerli Arthur30,0025,00

ZelleFormel
C20{=WENN(A20="";"";INDEX('Schiri Navi'!A1:AS250;VERGLEICH(A20;'Schiri Navi'!E1:E250;0);VERGLEICH(B11&E10;'Schiri Navi'!A1:AS1&'Schiri Navi'!A2:AS2;0)))}
C21=WENNFEHLER(SVERWEIS(A21;'Schiri Navi'!$E$3:$AI$189;VERGLEICH($B$11;'Schiri Navi'!$E$1:$AI$1;0);0);0)
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#7
Hallo Jockel

Danke für den Lösungsvorschlag. Das Problem ist, dass ich teilweise Vereine habe, die auf verschiedenen Anlagen spielen. Mit deiner Lösung vergleicht er zwar den ausführenden Verein, nicht aber den Austragungsort.
Ausserdem funktioniert diese Formel ja prächtig, ich brauche eine Lösung für das Blatt "Auslagen", Spalte AV.

Danke und Gruss, dänel
to top
#8
(02.05.2014, 17:37)Daenel schrieb: Hallo Jockel

Danke für den Lösungsvorschlag. Das Problem ist, dass ich teilweise Vereine habe, die auf verschiedenen Anlagen spielen. Mit deiner Lösung vergleicht er zwar den ausführenden Verein, nicht aber den Austragungsort.
Ausserdem funktioniert diese Formel ja prächtig, ich brauche eine Lösung für das Blatt "Auslagen", Spalte AV.

Danke und Gruss, dänel


okay, okay, ich will nicht streiten, wenn du meinst, deine formel sei pratkikabler (prächtig), als meine bitte... ich gebe nur zu bedenken in dem fall hier in deiner dieser datei kommen wir wohl immer zum gleichen ergebnis...

in deinem VERGLEICH() -->
PHP-Code:
VERGLEICH(B11&E10;'Schiri Navi'!A1:AS1&'Schiri Navi'!A2:AS2;0


beziehst du dich auf
Arbeitsblatt mit dem Namen 'AUFGEBOT2'
 BCDEF
10Würenlos Platz:Ländli
11TV WürenlosBesammlung:13.30 Uhr

ZelleFormel
B10=SVERWEIS(Dateneingabe!B6;Spieldetails!A3:I106;4;1)
E10=SVERWEIS(Dateneingabe!B6;Spieldetails!A3:I106;5;0)
B11=SVERWEIS(Dateneingabe!B6;Spieldetails!A3:I106;6;0)
F11=E9-"003000"
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

und bei diesem SVERWEIS() beziehst du dich wiederum auf die gleiche matrix...
cu jörg eine rückmeldung wäre ganz reizend XL2003 bis XL2013
to top
#9
Hallo Jockel

Du hast recht, ich finde deine Formel auch besser, vor allem weil sie keine Matrixformel ist. In meiner Formel (die ich auch nicht selber erstellt habe), müssen eben beide Zeilen übereinstimmen, also Schiri Navi Zeile 1 mit B11 UND Schiri Navi Zeile 2 mit E10.

Kann die 2. Bedingung auch in diese Formel?

Gruss
to top
#10
(02.05.2014, 17:58)Daenel schrieb: Kann die 2. Bedingung auch in diese Formel?

klar, Jörg kann das. Und wenn nicht mit dieser Formel, dann kennt er eine andere! Ich habe da vollstes Vertrauen!
Gruß Ralf

?mage

Die deutsche Rechtschreibung ist Freeware, d.h. du kannst sie kostenlos nutzen.
Allerdings ist sie nicht Open Source, deswegen darfst du sie nicht verändern oder in veränderter Form veröffentlichen.
to top


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  Schwieriges Problem | Index & Verweis Auswertung excelhexel 2 51 30.11.2016, 20:09
Letzter Beitrag: excelhexel
  Index (Vergleichsbefehl) mit mehreren Variablen? Franzi 79 5 103 21.10.2016, 22:31
Letzter Beitrag: Jockel
  Index Formel nach rechts ziehen und dabei Spalte fixieren Gwendolyn 2 151 30.09.2016, 19:28
Letzter Beitrag: schauan
  Makro für INDEX VERGLEICH Funktion Felixk 6 305 03.08.2016, 11:06
Letzter Beitrag: Felixk
  Index mit mehreren Kriteien sirphilipp 1 212 30.06.2016, 14:01
Letzter Beitrag: BoskoBiati
  Excel 2010 Index Vergleich gweste 2 362 16.06.2016, 18:38
Letzter Beitrag: WillWissen
  Index eines Feldes beibehalten Elke Boese 4 395 20.05.2016, 17:59
Letzter Beitrag: schauan
  "Bezug" in der Funktion Index aus Zelle auslesen jonny.m 2 346 19.05.2016, 16:18
Letzter Beitrag: jonny.m
  Index gibt falsches Datum zurück Gorgyporgy 14 919 25.04.2016, 15:52
Letzter Beitrag: shift-del
  reference INDEX/MATCH Funktion über verschiedenen Woorkbooks Schnezler 1 253 17.03.2016, 21:54
Letzter Beitrag: schauan

Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste