Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

"automatische" Nummerierung von Artikeln
#1
Hallo Liebes Excel-Forum,

(gleich zuvor, falls der Beitrag hier falsch ist, bitte verschieben)

Ich habe eine Frage und hoffe auf Eure HilfeSmile

Ich möchte ich einer Stückliste die Positionen durchnummerieren, aber natürlich unter Berücksichtigung der vorhergehenden Zeile.

Beispiel: In Zeile 1 steht ein Artikel, dann erhält dieser Artikel die Position 1 - steht nun erst in der dritten Zeile wieder ein Artikel soll Zeile 3 die Nummer 2 als Position erhalten.

Formel: =WENN(G10="";F9+1;F10+1) - also WENN(Zeile 2 = "leer"; DANN Position 1 + 1; SONST Position 2 + 1)

Screenshots sind beigefügt:
   
   
Antwortento top
#2
A3: =VERWEIS(9^9;A2:A$2)+1 ist es wohl nicht, aber vielleicht

A3: =INDEX(A$1:A2;WENN(B3>"";VERWEIS(2;1/(B$1:B2<>"");ZEILE(B$1:B2));ZEILE(A2)))+1
Antwortento top
#3
(13.01.2017, 21:10)lupo1 schrieb: A3: =VERWEIS(9^9;A2:A$2)+1

Super DankeSmile
Bekomme ich noch eine Erklärung zum Verständnis dazu? :p
Antwortento top
#4
Habe oben noch was angefügt.

Verständnis: Die Funktion sucht den letzten numerischen Eintrag darüber und addiert 1.

Die zweite richtet sich nach "Text oder nicht" in B.
Antwortento top
#5
Hmm, das ist leider noch nicht die Lösung:

   
   
Antwortento top
#6
Ich bin nun fast der einzige, der IMMER, wenn nötig, die Zelle vor die Formel schreibt.Smile Mehr Klarheit geht nicht.
Antwortento top
#7
Ok, in A3 eingefügt - aber die Formel zählt nicht :(
   
Antwortento top
#8
Etwas hübscher - und speziell für Dich eine Zeile höher beginnend ;):

A2: =WENN(B2>"";INDEX(A$1:A1;VERWEIS(2;1/(B$1:B1>"");ZEILE(B$1:B1)))+1;"")

A1: leer oder beliebige Startzahl
B1: Überschrift Text (nicht leer, keine Zahl!)
[-] Folgende(r) 1 Benutzer sagt Danke an lupo1 für diesen Beitrag:
  • CommanderStefan
Antwortento top
#9
(13.01.2017, 21:49)lupo1 schrieb: Etwas hübscher - und speziell für Dich eine Zeile höher beginnend ;):

A2: =WENN(B2>"";INDEX(A$1:A1;VERWEIS(2;1/(B$1:B1>"");ZEILE(B$1:B1)))+1;"")

A1: leer oder beliebige Startzahl
B1: Überschrift Text (nicht leer, keine Zahl!)

WIE auch immer Du das gemacht hast - es funktioniert ::) DANKE 

   
Antwortento top
#10
Hatte die Quelle für die unverständliche VERWEIS-Formel vergessen:

http://www.excelformeln.de/formeln.html?welcher=48 (unten)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste