Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Seriennummer ergänzen
#1
Hallo zusammen,

Ich wollte hier etwas nach fragen und hoffe hier sind Experten die mir eventuell helfen können!
Und zwar bekomme ich folgendes nicht hin:

Die Serien Nr. soll wie folgt erstellt werden:

z.B. Auftrag B2 (8001166) Teile-Nr. (nur der Zahlenwert) E2 (280) Typ (nur der Zahlenwert) F2 (400) Baujahr (nur die letzten beiden Ziffern) H2 (17).
Seriennummer => 800116628040017
Aber, die Formel sollte berücksichtigen, das wenn zwei gleiche Auftragsnummer, gleichzeitig aber auch Teile-Nr. und der Typ gleich sind noch eine -1,-2 usw. (siehe Bild) einfügt.

Ich bin für alle Vorschläge offen und hoffe auf ein positives Feedback eurer seits.

Liebe Grüße 
schachi85


Angehängte Dateien Thumbnail(s)
   
Antwortento top
#2
Hi,
schau mal ob es so paßt bei dir:


Tabelle1
ABCDEFGHIJ
1PosAuftragKundeKundennummerTeile-NrTypGewichtBaujahrSeriennummerSeriennummer
218001166KSM-280KSM-AV400 RD75 kg2017800116628040017800116628040017-1
328001166KSM-280KSM-AV400 RD75 kg2017800116628040017800116628040017-2
435165465KSM-280KSM-AV400 RD75 kg2017516546528040017516546528040017-1
545465214KSM-280KSM-AV400 RD75 kg2017546521428040017546521428040017-1
655465214KSM-280KSM-AV400 RD75 kg2017546521428040017546521428040017-2
761546554KSM-280KSM-AV400 RD75 kg2017154655428040017154655428040017-1
872588416KSM-280KSM-AV400 RD75 kg2017258841628040017258841628040017-1

verwendete Formeln
Zelle Formel Bereich N/A
I2:I8=B2&RECHTS(E2;3)&TEIL(F2;7;3)&RECHTS(H2;2)
J2:J8=I2&"-"&ZÄHLENWENN(I$2:I2;I2)
Excel-Inn.deHajo-Excel.deXHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007 Add-In-Version 22.01 einschl. 64 Bit



Hilfsspalte I kann ausgeblendet werden.

Sollten die Teile-Nr oder Typ auch anders aussehen, dann müßte die Formel geändert werden. Geht sicher auch einfacher, aber dazui fehlt mir leider das Wissen.
Mit freundlichen Grüßen  :)
Michael
Antwortento top
#3
Hallo, für I2 evtl. ..:

Code:
=B2&RECHTS(E2;3)&TEIL(F2;7;3)&RECHTS(H2;2)&"-"&ZÄHLENWENNS($B$2:B2;B2;$E$2:E2;E2;$F$2:F2;F2;$G$2:G2;G2;$H$2:H2;H2)
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2016
Antwortento top
#4
Hi Jörg,

auch netter Ansatz, aber was mir beim nochmaligen Lesen der Fragestellung auffiel: Die Ergänzung mit - und lfd. Nummer soll nur bei mehrmaligem Auftreten angefügt werden. Also bei den Positionen 3, 6 und 7 dürfte nix angefügt werden. Da fällt mir grad nix zu ein.
Mit freundlichen Grüßen  :)
Michael
Antwortento top
#5
Hallo zusammen,

vielen dank für eure mühe.
Wie Michael schon schrieb, soll Excel nur die Erweiterung (Aufzählung) schreiben wenn die Auftragsnummern gleich sind.

Kann mann da was machen?

vielen dank
Antwortento top
#6
Wenn ichs richtig verstanden habe dann ergänze die Formel in J2 um

=WENN(ZÄHLENWENN(B:B;B2)>1;I2&"-"&ZÄHLENWENN(I$2:I2;I2);I2)

Damit sollte nur bei den Werten die Unterteilung erfolgen deren Seriennummer doppelt sind
Früher dachte ich etwas über Office zu wissen, bis ich in diesem Forum ankam. Es gibt noch viel zu lernen.
Reaktionen auf angebotene Lösungen wären sehr nett.
Antwortento top
#7
bekomme ich leider nicht damit hin
Antwortento top
#8
Moin!
I2:J2 nach unten ziehen:

ABCDEFGHIJ
1ABCDEFGHHilfsspalteJ
218001166KSM-280KSM-AV400 RD75 kg2017800116628040017800116628040017-1
328001166KSM-280KSM-AV400 RD75 kg2017800116628040017800116628040017-2
435165465KSM-280KSM-AV400 RD75 kg2017516546528040017516546528040017
545465214KSM-280KSM-AV400 RD75 kg2017546521428040017546521428040017-1
655465214KSM-280KSM-AV400 RD75 kg2017546521428040017546521428040017-2
761546554KSM-280KSM-AV400 RD75 kg2017154655428040017154655428040017
872588416KSM-280KSM-AV400 RD75 kg2017258841628040017258841628040017
Formeln der Tabelle
ZelleFormel
I2=B2&RECHTS(E2;3)&TEIL(F2;7;3)&RECHTS(H2;2)
J2=I2&WENN(ZÄHLENWENN(I:I;I2)>1;"-"&ZÄHLENWENN(I$2:I2;I2);"")

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Gruß Ralf
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antwortento top
#9
Auch die Formel von Palomino funktioniert, ist eben nur anders aufgebaut als die von RPP63


Tabelle1
ABCDEFGHIJ
1PosAuftragKundeKundennummerTeile-NrTypGewichtBaujahrSeriennummerSeriennummer
218001166KSM-280KSM-AV400 RD75 kg2017800116628040017800116628040017-1
328001166KSM-280KSM-AV400 RD75 kg2017800116628040017800116628040017-2
435165465KSM-280KSM-AV400 RD75 kg2017516546528040017516546528040017
545465214KSM-280KSM-AV400 RD75 kg2017546521428040017546521428040017-1
655465214KSM-280KSM-AV400 RD75 kg2017546521428040017546521428040017-2
761546554KSM-280KSM-AV400 RD75 kg2017154655428040017154655428040017
872588416KSM-280KSM-AV400 RD75 kg2017258841628040017258841628040017

verwendete Formeln
Zelle Formel Bereich N/A
I2:I8=B2&RECHTS(E2;3)&TEIL(F2;7;3)&RECHTS(H2;2)
J2:J8=WENN(ZÄHLENWENN(B:B;B2)>1;I2&"-"&ZÄHLENWENN(I$2:I2;I2);I2)
Excel-Inn.deHajo-Excel.deXHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007 Add-In-Version 22.01 einschl. 64 Bit

Mit freundlichen Grüßen  :)
Michael
Antwortento top
#10
Hi Michael!
Aus der Threaderöffnung:
Zitat:Aber, die Formel sollte berücksichtigen, das wenn zwei gleiche Auftragsnummer, gleichzeitig aber auch Teile-Nr. und der Typ gleich sind

Daher sollte schon auf I:I und nicht auf B:B geprüft werden.
Allgemeiner Hinweis:
Ich weiß nicht, wie groß die Tabelle ist.
Da die Formeln aber sehr rechenintensiv sind, würde ich Spalte J kopieren, als Wert einfügen und danach die Hilfsspalte löschen.

Gruß Ralf
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste