Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert sind; Die von diesem Forum gesetzten Cookies düfen nur auf dieser Website verwendet werden und stellen kein Sicherheitsrisiko dar. Cookies auf diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Die Updates sind abgeschlossen. Bitte meldet eventuelle Bugs und Auffälligkeiten im entsprechenden Forum.
Sollte das Loginfenster nicht sichtbar sein, ist es unten links. Entweder Ihr loggt Euch dort ein oder löscht den Browsercache und versucht es noch einmal.


SVERWEIS funzt nicht, Formatproblem
#1
Hallo Leute,

ich habe ein Problem beim "Abfischen" von Daten mit SVWERWEIS...

Ausgangslage:

Gegeben ist mir eine Liste mit IP Adressen im Format 100200300400
Diese sind in einer Matrix im folgenden Format mit Bezeichnung beschrieben:
Spalte A1: Spalte B1:
100.200.300.400 Workstation1
(als Text formatiert)

Ich muss in meiner Ausgangsliste aus den IP Adressen "100200300400" etc. die Bezeichnung "Workstation1" etc. machen.

Problem: Die Punkte alle 3 Zeichen müssen eingefügt werden (mit Formel WERT?)
Danach kann ich mit SVERWEIS aber nicht die Spalte B1 abgreifen, da er meine 100.200.300.400 (Benutzerdefiniertes Format) in der Matrix (Text formatiert - darf ich nicht ändern) nicht findet.
Wenn ich meine benutzerdefinierten Felder in Text umwandeln möchte, bekomme ich "1,92168E+11" ??

Wer kann mir helfen?

Besten Dank im Voraus!
JP
Antwortento top
#2
Hallo,

könntest Du eine Beispieldatei hier hochladen?

http://www.clever-excel-forum.de/thread-326.html
Gruß Stefan
Win 7 / Office 2007
Antwortento top
#3
Hallo Steffl,

gerne.

Gruß
JP


Angehängte Dateien
.xlsx   IP Adressen etc.xlsx.xlsx (Größe: 13,62 KB / Downloads: 7)
Antwortento top
#4
Hallo

warum sind in Tabelle 1 die ID ohne Punkt? Wie kommen die dahin? warum werden die nicht von der Referenztabellen übernommen?? dann funktioniert es ja
Gruß
Fred0



Meine Antworten sind freiwillig und ohne Gewähr!
Wenn nichts angegeben beziehe ich mich auf Excel 2016

Antwortento top
#5
Hallo Fred0,

ich bekomme die Spalte B ohne Punkte vorgegeben (und soll die Punkte auch nicht einzeln manuell hinzufügen) und muss diese mit den Punkten bestücken, damit ich die Bezeichnungen aus der Ref.-Tabelle mit SVERWEIS heranziehen kann. So lautet die Aufgabenstellung laut IHK Prüfung.

In der Lösung wird angegeben: Die IP-Adressen können mit der Funktion VERKETTEN in das entsprechende Format gebracht werden. Mehr Tipps gabs aber nicht und ich weiss nicht, wie ich die Funktion Verketten hier anwenden soll :-(
Antwortento top
#6
(06.04.2015, 19:37)Jeanpierre1983 schrieb: Hallo Fred0,

ich bekomme die Spalte B ohne Punkte vorgegeben (und soll die Punkte auch nicht einzeln manuell hinzufügen) und muss diese mit den Punkten bestücken, damit ich die Bezeichnungen aus der Ref.-Tabelle mit SVERWEIS heranziehen kann. So lautet die Aufgabenstellung laut IHK Prüfung.

In der Lösung wird angegeben: Die IP-Adressen können mit der Funktion VERKETTEN in das entsprechende Format gebracht werden. Mehr Tipps gabs aber nicht und ich weiss nicht, wie ich die Funktion Verketten hier anwenden soll :-(

Hallo, das geht so..:

Arbeitsblatt mit dem Namen 'Tabelle1'
 BCD
14192168001003192.168.001.003Workstation
15192168002001192.168.002.001Arbeitsplatz-PC

ZelleFormel
C14=TEXT(B14;"000"".""000"".""000"".""000")
D14=SVERWEIS(C14;Referenztabellen!$A$1:$B$20;2;0)
C15=TEXT(B15;"000"".""000"".""000"".""000")
D15=SVERWEIS(C15;Referenztabellen!$A$1:$B$20;2;0)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
Antwortento top
#7
Hallo Jörg,

die Rettung! vielen vielen Dank!
Einfach als Text formatieren und die Punkte setzen...genial Smile

Besten Dank auch an die Anderen, die sich das Problem angeschaut haben!
Schönen Abend,
JP
Antwortento top
#8
Hallo Jörg,

da reicht doch das:


Code:
=SVERWEIS(TEXT(B2;"000.000.000.000");Referenztabellen!$A$1:$B$20;2;0)
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#9
(06.04.2015, 22:06)BoskoBiati schrieb: Hallo Jörg,

da reicht doch das:



Code:
=SVERWEIS(TEXT(B2;"000.000.000.000");Referenztabellen!$A$1:$B$20;2;0)

Hallo Edgar, sicher, sicher, ich hatte mich an die Vorgabe gehalten, aber Recht hast Du: Das geht [auch einfach(er)] so... 15
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2013
Antwortento top
#10
Hallo Jörg,

Vorgabe war VERKETTEN. Das ginge dann so:


Code:
=SVERWEIS(TEIL(B2;1;3)&"."&TEIL(B2;4;3)&"."&TEIL(B2;7;3)&"."&TEIL(B2;10;3);Referenztabellen!A:B;2;0)
=SVERWEIS(Verketten(TEIL(B2;1;3);".";TEIL(B2;4;3);".";TEIL(B2;7;3);".";TEIL(B2;10;3));Referenztabellen!A:B;2;0)
Gruß
Opa Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste